Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Space added above and below Source Sans Pro and Roboto Adobe fonts

New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I recently deactivated the Google Font versions of Source Sans Pro and Roboto/Roboto Condensed and then activated the Adobe versions. I'm now having issues with space being added above my text.

 

I searched for some answers and while I have learned that I can adjust the baseline to force the text to align with the top of a text box, this doesn't seem like a long-term solution. I'd simply prefer the text to default to aligning with the top of a text box.

 

See screenshot below. Any help would be welcome!Screen Shot 2021-06-10 at 2.35.54 PM.png

TOPICS
Type

Views

184

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi Anneka,

why don't you stay with the Google font files?

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Actually, this is correct behaviour if your text boxes are set to a baseline alignment of "Ascent" and the font is designed with a large ascent from the baseline, for whatever reason: (usually to accommodate accents and special glyphs).

 

Attached shows the difference in Ascent for Roboto versus Minion

 

InDesign has several alignment options to accommodate and lessen this effect: For what you desire, make your text boxes align to Cap Height instead  :  Text Frame Options > Baseline Options > Cap Height

If you want to make that your ID default, close any open documents and set it before you open a new document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

LATEST

Hi Anneka,

I think we have an issue here.

Below a screenshot, side by side from my German InDesign 2021 with two text frames with exactly the same settings and values for First Baseline in the frames. Both frames are selected, the Text Frame Options show all values, so they are identical. However, what's not identical is the position of the first baseline in the frame.

 

The value applied now for First Baseline is ASCENT_OFFSET, "Oberlänge" in my German InDesign, that's the default if you do a fresh install of InDesign:

 

FirstBaseline-GoogleFont-vs-AdobeFont-1.PNG

 

Let's see if we can synch both baselines; try any other of the values like CAP_HEIGHT, FIXED_HEIGHT, LEADING_OFFSET or X_HEIGHT and you'll see that both fonts are in synch now. Below the example for CAP_HEIGHT:

 

FirstBaseline-GoogleFont-vs-AdobeFont-CAP_HEIGHT-3.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines