• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Weird jumping elements while clicking with mouse/ trackpad in InDesign on macOS

Participant ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

Hi,

since I go my MacBookPro (15" 2017) I have an annoying bug in InDesign. First I thought its related to the trackpad. But a friend with the exact same specs doesnt have this problem.

When I click on a shape (either with Magic Mouse 2 or Trackpad) sometimes it jumps a little aside. Pretty annoying when you try to work fast and dont want to undo everything over and over again. I insert a gif to demonstrate it. If you look closely you can notice the little jump.

Also, it looks like some click "doesnt count". When I try to select the color in the color menu it cant be selected and after multiple clicking it takes it.

At work on my iMac I never had this problem. Also tried reinstall InDesign. I believe its some third party software that creates this issue. But I dont want to fully reset my MacBook. Is there a way to only boot with InDesign? I think in safeboot also InDesign is disabled right? Or how can I test what app it is or what InDesign setting / Mac setting is messed up?

I think its not my fault how fast I click/ move the mouse, because I just do the same at work (iMac, Magic Mouse) without this issue.

While trying to record the color problem I noticed that my cursor swapped to a small hand icon, like its trying to move the color. I think the same thing happens to my shapes. Like the mouse is holding "too long". Is there a way to control this anywhere?

I hope its related enough to InDesign because I think the error isnt withing InDesign. But its the only program I notice this issue. Non of the other CC programs.

Thanks for your help.

InDesign-Bug.gif

{Renamed by MOD}

Views

2.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Participant , Aug 10, 2019 Aug 10, 2019

Ok I fixed it with safeboot. I first started InDesign and didnt have this problem. Then I started my apps one by one and tested every time. I think the problem is the app "Better Snap Tool".

To fix it I disabled the app for InDesign (can be done in the BST Settings).

But its still pretty strange because I use just the same program with the same settings on my iMac at work. Only difference is that the iMac is on Sierra and not Mojave.

Votes

Translate

Translate
Community Beginner , Feb 27, 2024 Feb 27, 2024

I've been trying to figure this out for months! Thank you so much for this insight. Unchecking "snap windows by dragging" actually didn't work for me, but when I was in InDesign and selected the Magnet dropdown menu, there was an option to "Ignore InDesign" which seems to have done the trick. You may have saved my sanity!

Votes

Translate

Translate
Adobe Employee ,
Aug 08, 2019 Aug 08, 2019

Copy link to clipboard

Copied

Hi Jona,

Thanks for reaching out. I could see that you are facing some performance issues while using the mouse/ trackpad in InDesign. I completely understand how frustrating it could be in the middle of a project. Let us make this right for you. I would request if you can share a few more details like:

  • OS (exact version of macOS)
  • Exact version of InDesign
  • Is the issue related to a specific document? Try checking on a new file.
  • Where the files are generally saved (Network Drive/ System HDD/ Shared Folder on System /External HDD)?
  • Are there any recent changes made to your system? For example, any antivirus, system updates or web extensions installed recently.
  • Try booting the system in Safe mode: Start in Safe Boot mode for Adobe products on Mac OS X  and check how InDesign works there. In Safe mode, all the third-party applications and services closed until you open them.

Looking forward to your response!

Regards,

Srishti

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 10, 2019 Aug 10, 2019

Copy link to clipboard

Copied

Hi, thanks for your reply. I will test the safe boot as soon as I can.

OS Version: Mojave 10.14.5 (18F132)

InDesign Version: 14.0.2

Not document related, happens in every document

InDesign located on internal Mac SSD, Document the same (on the desktop)

No recent changes, I have this problem for a long time now (about half a year) but I dont know what happened there.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 10, 2019 Aug 10, 2019

Copy link to clipboard

Copied

Ok I fixed it with safeboot. I first started InDesign and didnt have this problem. Then I started my apps one by one and tested every time. I think the problem is the app "Better Snap Tool".

To fix it I disabled the app for InDesign (can be done in the BST Settings).

But its still pretty strange because I use just the same program with the same settings on my iMac at work. Only difference is that the iMac is on Sierra and not Mojave.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

I had a very similar issue in Premiere Pro 2022 and After Effects 2022 on my 2016 Macbook Pro. When I click-dragged down, the mouse would "teleport" towards the top of the screen. Thanks to your discovery, it was caused by an app called Magnet, an alternative to Better Snap Tool. Magnet does not have the option to enable/disaple specific apps, however, if you go to preferences and uncheck the box "Snap windows by dragging," it fixed the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Thank you! My wife just started having this problem and Magnet was the culprit. We did everything including g reinstalling CC.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 19, 2023 Dec 19, 2023

Copy link to clipboard

Copied

Hi @GradyG7,

 

Sorry to hear about the trouble. Was the issue resolved? If not, please share the version of InDesign, OS, & system configuration. We'll try our best to assist you with this.

 

Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2023 Dec 19, 2023

Copy link to clipboard

Copied

Thank you for checking. Yes we determined the new update for Magnet caused this issue. Just grateful someone pointed this out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

Glad to hear that it works! Feel free to reach out if you need further assistance. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

I've been trying to figure this out for months! Thank you so much for this insight. Unchecking "snap windows by dragging" actually didn't work for me, but when I was in InDesign and selected the Magnet dropdown menu, there was an option to "Ignore InDesign" which seems to have done the trick. You may have saved my sanity!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

Thank you! This is even better, had no idea.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

LATEST

Glad to hear that! Feel free to reach out if you need further assistance. 

Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines