Highlighted

Viewing page with placed image causes document to be marked as dirty (needs saving)?

Community Beginner ,
Jul 07, 2020

Copy link to clipboard

Copied

When I open an InDesign file, after I first view any portion of a page that has a placed image on it, roughly 2-10 seconds later the document gets marked as dirty (asterisk by the filename). It's odd, and kind of annoying, both because of the needless prompt for saving when I close it, and because when I'm deep in the weeds opening and looking through multiple documents it can make me second-guess whether I actually *do* need to save something.

 

I assumed this was a bug and made a report... but then I thought to try it in earlier versions, and it's happening all the way back to 14.0.3. (I jumped straight from CS3 to CC recently.)

 

So now I'm second-guessing myself: is this actually expected behavior? Is something really being changed / updated when a page containing a link is rendered? (If it's just that I have some preference set that's, I don't know, dynamically adjusting some layout setting based on linked images, I'm going to feel both kind of silly and rather relieved.)

 

[EDIT: I don't seem to be able to make >1 correct answer show; the TL;DR is:

 • No, it's not expected behavior;

 • It only happens for PNGs, and only when the PNG is at higher than 72dpi resolution.]

Well, I just replicated it.

 

In my tests, I started with a transparent .psd (which is what I would normally use), then this morning used Photoshop's File > Export > Quick Export as PNG (72 ppi/225 ppi) and finally used File > Export > Export as and exported 2x the original size (72 ppi/450 ppi)—that's what did it. 

 

Eric, I would add a link to this thread on your bug report.

 

~Barb 

Topics

Bug

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Viewing page with placed image causes document to be marked as dirty (needs saving)?

Community Beginner ,
Jul 07, 2020

Copy link to clipboard

Copied

When I open an InDesign file, after I first view any portion of a page that has a placed image on it, roughly 2-10 seconds later the document gets marked as dirty (asterisk by the filename). It's odd, and kind of annoying, both because of the needless prompt for saving when I close it, and because when I'm deep in the weeds opening and looking through multiple documents it can make me second-guess whether I actually *do* need to save something.

 

I assumed this was a bug and made a report... but then I thought to try it in earlier versions, and it's happening all the way back to 14.0.3. (I jumped straight from CS3 to CC recently.)

 

So now I'm second-guessing myself: is this actually expected behavior? Is something really being changed / updated when a page containing a link is rendered? (If it's just that I have some preference set that's, I don't know, dynamically adjusting some layout setting based on linked images, I'm going to feel both kind of silly and rather relieved.)

 

[EDIT: I don't seem to be able to make >1 correct answer show; the TL;DR is:

 • No, it's not expected behavior;

 • It only happens for PNGs, and only when the PNG is at higher than 72dpi resolution.]

Well, I just replicated it.

 

In my tests, I started with a transparent .psd (which is what I would normally use), then this morning used Photoshop's File > Export > Quick Export as PNG (72 ppi/225 ppi) and finally used File > Export > Export as and exported 2x the original size (72 ppi/450 ppi)—that's what did it. 

 

Eric, I would add a link to this thread on your bug report.

 

~Barb 

Topics

Bug

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 07, 2020

Copy link to clipboard

Copied

No. Nor can I replicate the behavior. Was the file you are opening created in an earlier version than you are using now? Are you opening the file from a local drive, or a network drive or a file-sharing service?

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 07, 2020

Copy link to clipboard

Copied

While I did first notice it with a file created in an earlier version, that's not the only place I'm seeing it - I can reproduce with a completely new, blank file to which I add a single small linked image. (See linked bug-report for exact steps.)

 

The image file is on a local drive, in the same directory as the .indd file.

 

I do have two services that monitor local files and sync them to the cloud, but if I pause them the behavior continues. (And even if they were doing something weird and touching any file I open, I'd expect to see it after any file-open, rather than only happening when I go to a page with a linked image.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

Hi Eric,

thank you very much for posting this!

I can see this issue as well with my German InDesign 2020 version 15.1.1.103 on Windows 10.

Also placed a PNG file ( with transparency ).

 

Now I tested with CC 2019 and yes, the issue is there as well.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

Hi Barb,

did you place a PNG file with transparency?

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

Hi Eric,

tested on with a different kind of image:

A tif file with no transparency: 1-Bit

 

Here I cannot see the issue.

Either the cause of the issue is the PNG file format and/or the transparency in the file, I think.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

OK,  tried it again with a PNG with transparency. Followed these steps:

1. Create a new empty document.
2. Add a second page to the document.
3. Place image, onto the page you're viewing (I did a PNG)
4. Save and close the document.
5. Open the document.
6. Wait 2-20 seconds several minutes, doing nothing to change the document.

 

The asterisk never appeared. 

Mac 10.15.5

InDesign 15.1.1

 

~Barb 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...