Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Address lookup and Face detection tasks stuck and never complete

Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I have a catalog of about 48k pictures. I enabled face detection, and it used to run automatically when I imported new pictures.

But lately, it either no longer runs, or starts, but doesn't complete.

For instance, right now, I see the Face detection task stuck on "Indexing 4 photos". It is not in the paused state. If I pause and resume it , nothing happens. CPU is at near 0 in task manager. It is not making any progress.

I also have the Address lookup task stuck the same way.

Neither of these tasks ever complete.

I went to Edit / Preferences / Restart Lightroom classic. The tasks come back and stil don't make any progress or ever complete.

I also tried disabling Address lookup and Face detection in Edit / Library / Catalog settings.

Still, the tasks never complete and never go away.

Is there any fix for this ?

 

 

 

 

 

Pentax K-1 II . Panasonic Lumix GX85.

i7-5820k OC 4.3 GHz
32GB DDR4-2666
8x1 TB striped SSD
nVidia GTX 960
2 x 32UHD59-B 32" 4K displays
1 x Asus PB238Q HD display
10Gbe Ethernet

112TB NAS
TOPICS
Bug, Crash or freeze, Problem or error

Views

103

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I have gone as far as uninstalling and reinstalling Lightroom Classic. This does not solve the problem. The tasks come back and won't complete.

 

Pentax K-1 II . Panasonic Lumix GX85.

i7-5820k OC 4.3 GHz
32GB DDR4-2666
8x1 TB striped SSD
nVidia GTX 960
2 x 32UHD59-B 32" 4K displays
1 x Asus PB238Q HD display
10Gbe Ethernet

112TB NAS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

There may be one or more "poison" photos that LR is (incorrectly) getting stuck on. To see if that's the case, you can use a mildly tedious divide-and-conquer:

 

1. Pause Face Detection.

 

2. In the Folders panel on the left, select the first half of your folders. 

 

3. Do the command Library > Find Faces Again, with these options:

johnrellis_0-1618595848419.png

4. If face detection hangs on at least one remaining photo, then you know one of the poison photos is in that first half of folders you've selected.  If it doesn't hang, then the poison photos are all in the second half of the folders.

 

5. Choose the half of the folders with poison photos and repeat steps 2-4 until you've narrowed down one folder for which face detection hangs.

 

6. Use the same process with the photos of that folder, repeatedly subdividing them into halves until you've identified one photo that hanges face detection.  This process only needs 15 iterations to handle 32K photos.

 

Once you've identified a poison photo, upload it (and its .xmp sidecar, if it has one) to Dropbox or similar and post the sharing link here. We can see if it hangs other LR installations and then proceed from there.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

I am not confident that it has anything to do with a poison photo. I think it's a catalog issue. Your instructions didn't help. After step 3, face detection did not run. After I restarted Lightroom, the face detection task was back, indexing just 4 photos, rather than half the photos in the catalog that I had selected previously.

 

I restored a catalog backup from October, that was done automatically by Lightroom prior to the v10 upgrade.

I then synchronized the top picture folder, and it imported all the missing photos since that date. Face detection ran on over 1000 pictures, and completed with no issue. It looks like the newly rebuilt catalog works OK, and the one I was using is somehow corrupt beyond repair, despite having been checked for integrity by Lightroom.

 

Despite having run "Find all missing photos" to remove missing files, and "Synchronize folder" on the top folder of both catalogs, there is a different number of files in each catalog.

The problematic catalog has only 23026 DNGs, vs 23058 for the rebuilt catalog.

The problematic catalog has only 24795 JPEGs, vs 24848 for the rebuilt catalog.

 

From the top picture folder, "DIR/S *.JPG" at the command line finds 25721 JPEGs ..

"DIR/S *.DNG" finds 23055 DNGs ...

 

The mystery deepens, has neither catalog contains all the files on disk. The newly rebuilt catalog has actually has 3 more DNGs than are contained on disk. But is still missing a lot of JPEGs.

 

Sigh.

 

Pentax K-1 II . Panasonic Lumix GX85.

i7-5820k OC 4.3 GHz
32GB DDR4-2666
8x1 TB striped SSD
nVidia GTX 960
2 x 32UHD59-B 32" 4K displays
1 x Asus PB238Q HD display
10Gbe Ethernet

112TB NAS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

LATEST

So I just built a brand new test catalog, without face detection or address lookup, and adding the photos in place (not moving them). Since my photos are on a striped 8 x 1 TB SSD array, it didn't take all that long.

 

Good news : his brand new catalog has the correct number of DNGs that matches the count of files on disk - 23055.

 

Bad news : it only has 24845 JPEGs, though, vs 25721 on disk. I wonder what happened to the missing 876 JPEG files. It's possible there are some corrupt JPEGs on disk. But how could I see which files Lightroom rejected ?

 

Worse news : neither of the other catalog (problematic one, and rebuilt from backup) have the correct number of DNGs or JPEGs, and functions such as "Find all missing photos" and "Synchronize folder" don't help.

 

Pentax K-1 II . Panasonic Lumix GX85.

i7-5820k OC 4.3 GHz
32GB DDR4-2666
8x1 TB striped SSD
nVidia GTX 960
2 x 32UHD59-B 32" 4K displays
1 x Asus PB238Q HD display
10Gbe Ethernet

112TB NAS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines