Can I get a Lightroom download for macOS 10.13.6 High Sierra

Explorer ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

My M1 Mac Mini is at home.  I am traveling with an old 2010 MacBook Pro.  

I am stuck at macOS 10.13.6 High Sierra.

I had Lightroom on this MacBook a few months ago but did a fresh install to clean up a lot of garbage.

Now I'm away from home with no Lightroom.

I just want to import, cull, and maybe do some basic editing before I get home to my M1 Mac Mini.  

Can someone point me to a download of an older version that will work?

TOPICS
macOS

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Dec 28, 2021 Dec 28, 2021

The only Lightroom Classic downloads you can get any more require OSX 10.14 or later

Likes

Translate

Translate
LEGEND ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

The only Lightroom Classic downloads you can get any more require OSX 10.14 or later

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Thanks

Darn

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Does a workaround to this limitation exist? I'm also on holiday with an old but fully working MacBook Pro

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Since I wrote the above, there are now ways to download earlier versions, depending on which earlier versions you might want. Please be specific about your needs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

My need is whatever Lightroom version I can get that will run on macOS 10.13.6 High Sierra

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

As I am not a Mac expert, perhaps you could do the research and find out what versions of Lightroom Classic do run on this operating system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

LATEST

It's a little complicated.

LrC is only available with the Photograph Plan which includes Photoshop/ Bridge/ Camera Raw, Lightroom Classic and Lightroom (cloud centric) and Lightroom Mobile.

At present you need LrC 10.4 to use the sync options with Lightroom and Lightroom Mobile.

LrC 10.4 requires Mac 10.14 Mohave to function.

The reality is your Mac is not up to the task.

Do you have a license key for Lightroom version 6?

 

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.8,; LrC 11.4.1, Lr 5.4.1, Ps 23.3.2-ACR 14.4,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines