Filters not Sticking 11.3.1

Explorer ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Not sure if this is a bug or something on my particular computer. 

On my main iMac that I've used for years, if I select only 4 star+ images, that setting sticks. So if I quit lightroom, then open it again, the 4 star+ are shown. 

However, recently I've been using LR Classic on my MacBook Pro M1 Pro and noticed that the Filters do not stick. In fact, they don't even show by default at the bottom of the screen (right hand side). So every time I quit LR I have to go and choose 4 star+ 

It's really annoying. As I've only recently started using the MBP for LR, I don't know if this is connected to it being an M1 Mac, Big Sur or the latest verson of LR. However, my iMac is (was) also running the latest version and it would remember the settings when LR quit.

PS - I can't test the iMac right now, as it died on me on Friday and is currently in for repair. It's a 2020 i9. But the problem is repeatable. 

Anyone else have this issue? Maybe it's a setting somewhere that I've forgotten to tick. But I've been through the pref panels many times and cannot see anything. 

Hampshire Wedding Photographer / Documentary Wedding Photographer
TOPICS
macOS

Views

61

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , May 09, 2022 May 09, 2022
[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.] 1. Do the menu command View > Show Filter Bar to show the main Filter bar at the top of the LR window (keyboard shortcut shown in the menu). 2. If the lock icon at the right end of the Filter bar is open, click it to close it: Alternatively, make sure the menu item File > Library Filters > Lock Filters is checked.

Likes

Translate

Translate
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Look at the far right side of the filter bar. There is a lock icon. Click on it so it gets closed.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Sorry, there's no lock icon on my LR Classic - and I can't ever remember seeing one on the filter bar. 

There is a toggle switch. Goes up and down. Up seems to engage the filter set. But when I quit, then reload, that switch goes down (Filters unset). 


Hampshire Wedding Photographer / Documentary Wedding Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

1. Do the menu command View > Show Filter Bar to show the main Filter bar at the top of the LR window (keyboard shortcut shown in the menu).

 

2. If the lock icon at the right end of the Filter bar is open, click it to close it:

johnrellis_0-1652147228670.png

 

Alternatively, make sure the menu item File > Library Filters > Lock Filters is checked.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Brilliant - Thank you John. 

I was looking at the bottom right of the screen, which is where I normally select my stars to show. Not at the top bar, which is why i didn't see the little lock icon. And I didn't even know that there was a lock option in the File Menu. It's buried. 

All sorted now though - so a huge thank you. It was frustrating me not to be able to get it to lock. 

Hampshire Wedding Photographer / Documentary Wedding Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

LATEST

Johan, your answer was in fact correct. The problem being there are two filter bars. The one at the top - that you were referring to but there is also the one at the bottom, which is the one I use most often. So I totally missed that the top bar has a lock icon, whereas the bottom one does not. 

John's reply saying to lock it via the File Menu worked for me. Then it was only after that and his screenshot, that I noticed the lock icon on the top filter bar. 


Hampshire Wedding Photographer / Documentary Wedding Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines