Issue filtering photos by date under the Metadata library filter

New Here ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

Windows User running 11.3.1.   I'm hoping someone can explain this to me.  When I select a folder of photos and go up to the top of my LrC display to Library Filters, select Metadata and select one of my 6 available windows to DATE, I'm supposed to be shown what I though was the capture date of these selected photos.  If I choose a date, I'm getting several files with a different dates than what the capture date shows.  When I went to the Metadata panel on the right side of my page and customized that panel with all the metadata date fields I could find (e.g. Capture Date, Capture Date/Time, Date Time, Date Time Original, and Debug Capture Time), the only metadata field that matched with my filtered search was Debug Capture Time.  I don't even know where this populates from, as I scanned these images in at a date after that date, and I certainly edited the actual photo Capture Date using Edit capture time to a very different time than what was shown.  Am I missing something?  I really need to be able to filter photos on Capture Date.

TOPICS
Windows

Views

44

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 12, 2022 May 12, 2022

Copy link to clipboard

Copied

LATEST

"I scanned these images in at a date after that date"

 

LR has longstanding bugs with photos missing capture dates in their metadata (e.g. scans). Adobe has never prioritized fixing these.:

https://community.adobe.com/t5/lightroom-classic-bugs/p-still-inconsistent-capture-date-time-for-pho... 

 

The core problem is that the LR catalog stores the capture date for a photo in multiple places, and those multiple values can get out of sync for scans.

 

To avoid these bugs, always make sure to do Metadata > Edit Capture Time on such photos.  Tip: If you select a batch of photos and do Edit Capture Time then Change All, that ensures all those photos have the same date/time internally as displayed on their thumbnails in Library Grid view. Note that this does not, repeat not, repeat not change all the photos to have the same date/time. It's harmless to do this on photos for which you have previously done Edit Capture Time.

 

I think it's likely that the problem photos in your screenshot didn't have Edit Capture Time run on them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines