• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Lightroom Classic won't save preset and masks

New Here ,
Nov 19, 2023 Nov 19, 2023

Copy link to clipboard

Copied

Hi, Im at a total loss. In the last 4 weeks, none of my edits will change in lightroom. I am applying the preset I have used before, making some masking edits and I then copy these edits and paste them onto the next image. When I go back to the previous image, it has an exclamation mark and says 'Some AI masks need to be updated'. It wont save any of them. it is so frustrating and i have uninstalled the app and nothing changes. 

 

Please help - I have 3 sessions i have to edit for clients! 

TOPICS
macOS

Views

54

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 19, 2023 Nov 19, 2023

Copy link to clipboard

Copied

LATEST

There have been scattered reports about this. LR stores the computed AI masks in the file "<catalog>.lrcat-data" in the catalog folder. If LR can't write that file, e.g. because it got corrupted somehow or has the wrong permissions, then you'll get the notification that the masks need updating. 


Troubleshooting steps:

 

1. Ensure LR is granted Full Disk Access (not Files And Folders) permission:
https://community.adobe.com/t5/lightroom-classic-discussions/quick-tips-how-to-give-full-disk-access...

 

Without Full Disk Access, LR can do all sorts of screwy things. If this doesn't fix the problem, then do the following:

 

2. Do Catalog Settings > General > Show, which will open the catalog folder in Finder.

 

3. Exit LR.

 

4. Rename the file "<catalog>.lrcat-data" to "<catalog>.lrcat-data.old".

 

5. Start LR.

 

6. Go to Library, click All Photographs, select all photos, and do the menu command Photo > Develop Settings > Update AI Settings.  That will recompute the AI masks on all your photos, which could take a very long time.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines