Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


LR Curve adjustment difficult on MacOS Sierra

New Here ,
Jul 11, 2016 Jul 11, 2016

Copy link to clipboard

Copied

I'm running the latest CC with the MacOS Sierra Beta on a rMBP-13. I've noticed that adjusting curves is incredibly difficult. I can't make a minor adjustment to any point, it's  a massive jump requiring a lot of touchpad movement. Similarly, scrolling to adjust brush size is either very large or small.

Anybody else have this issue? !

Views

17.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Apr 12, 2017 Apr 12, 2017
Works for me now finally with LR 2015.10 and macOS 10.12.4. Thanks for fixing. It's been a long wait.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 12, 2016 Jul 12, 2016

Copy link to clipboard

Copied

For the tone curve fine adjustment, try holding down the Alt/Option key as you drag a curve point.

The brush size adjustment could more likely be a preference in the touch-pad setup, as it would for a mouse scroll wheel.

Regards. My System: Lr-Classic 10.4, Photoshop 22.5, Lightroom 4.4, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2016 Sep 26, 2016

Copy link to clipboard

Copied

Same issue, even on version 6.7 and official release of MacOS Sierra...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2016 Sep 26, 2016

Copy link to clipboard

Copied

Same issue here on my system (Sierra, latest official release). Tried to reinstall creative cloud, lightroom, drivers and so on. Still the same problem!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 26, 2016 Sep 26, 2016

Copy link to clipboard

Copied

There is an other thread active here, with the same theme.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2016 Sep 26, 2016

Copy link to clipboard

Copied

show me pls.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 28, 2016 Sep 28, 2016

Copy link to clipboard

Copied

Is Lightroom compatible with macOS Sierra?[was: Sierra]

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 30, 2016 Sep 30, 2016

Copy link to clipboard

Copied

I'm having the same issue with curves now that I've upgraded to macOS Sierra. Anyone find a resolution yet?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2016 Oct 01, 2016

Copy link to clipboard

Copied

nope dont think so 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2016 Oct 03, 2016

Copy link to clipboard

Copied

Also experiencing this... I tweak the curve pretty much every shot... so this is a big deal for me.  This frustrates, especially considering Adobe gave Sierra a green light at launch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2016 Oct 04, 2016

Copy link to clipboard

Copied

Same problems with the tone linear curve adjustment. Moving the corner points with any kind of accuracy is an exercise is frustration. Also, the color sliders don't work correctly when using the color cursor selector. The thing is, Camera Raw 9.7 and Photoshop work OK, no problems with those. Come on Adobe, I and others have paid our annual fee. Fix this.

Lightroom 2015.7, Camera Raw 9.7, Photoshop 2015.5 and Sierra

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 04, 2016 Oct 04, 2016

Copy link to clipboard

Copied

I was having a tone curve issue with LR 6.5 or 6.6 on El Capitan but updating to 6.7 fixed it. Still on El Capitan though.

Now using Affinity Photo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2016 Oct 17, 2016

Copy link to clipboard

Copied

Same problem with the tone linear Curve adjustment in Lightroom 6.7 on macOS Sierra. Adobe must to lunch an update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2016 Oct 21, 2016

Copy link to clipboard

Copied

There is no solution yet??? Adobe come on.. learn from Capture one

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2016 Nov 05, 2016

Copy link to clipboard

Copied

I can confirm the problem. macOS Sierra and using Tone Curve is almost impossible, very frustrating...

Same with brush sizes.

Waiting for Adobe to see this problem and solve 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2016 Nov 06, 2016

Copy link to clipboard

Copied

Facing the same issue on the tone curve whereby its hard to control the points freely, ever since i updated to Mac OS sierra 10.12.1 and Lightroom CC 2015.7. Hoping to see this problem solve as soon as possible

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

I can confirm the same Issues. Adobe please fix it!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2016 Nov 15, 2016

Copy link to clipboard

Copied

Also have this problem it is frustrating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

stilll no solution...thats sick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

Same issue here. Hope this gets fixed soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2016 Nov 20, 2016

Copy link to clipboard

Copied

Not being able to use Tone Curve in LR 2017 on Sierra is so annoying I want to throw my workstation through the window. Please guys, check your updates more carefully. We depend on you with our professional lives.

p.s. Have a great day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2016 Nov 21, 2016

Copy link to clipboard

Copied

I can confirm, having the same issue with Sierra. This has been going on for a while and I'm sick of it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2016 Nov 23, 2016

Copy link to clipboard

Copied

Same thing here. Infuriating to say the least. Running MacOS 10.12.1 on Early 2013 MacBook Pro Retina. Please help Adobe... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2016 Nov 23, 2016

Copy link to clipboard

Copied

I'm a little surprised that at this point there are only 22 replies to this. Makes me wonder how widespread this issue is and if there isn't something specific to our having encountered it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2016 Nov 23, 2016

Copy link to clipboard

Copied

I totally agree. Makes me wonder if a person just needs to do a fresh install or something? Or maybe a prefs dump? Those are such simple troubleshoots, however no one has suggested that at all. Very curious...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2