• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

LRMogrify2 and Catalina OS

Explorer ,
Nov 15, 2019 Nov 15, 2019

Copy link to clipboard

Copied

After installing IOS Catalina I have lost the use of LRMogrify2. I get an error message

"magick cannot be opened because the developer cannot be verified"

"Failed to run Mogrify..more info in the txt file"

It appears to me that a new security feature has been added via Catalina.

How to I get LRMogrify2 to work again?

Thanks for any help in this matter.  NH

TOPICS
macOS

Views

7.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

LEGEND , Nov 15, 2019 Nov 15, 2019

Looks like the plugin developer hasn't updated LR/Mogrify 2 to cope with the extra security of Mac OS 10.15 (Catalina).

 

1. Send an email to the developer pointing this out.  See the contact info at the bottom of this page:

https://www.photographers-toolbox.com/products/lrmogrify2.php?sec=faq

 

Suggest that the first time plugin runs, it execute the command "xattr -r -d com.apple.quarantine path", where path is _PLUGIN.path.

 

2. To work around this installation bug:

 

a. In Finder navigate to the folde

...

Votes

Translate

Translate
LEGEND , Nov 16, 2019 Nov 16, 2019

Correction in step 2d: "mogrify" => "magick"

 

[Use the reply button under the first post to ensure replies sort properly.]

Votes

Translate

Translate
LEGEND ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

I just tried the installation recipe from above and it worked on my LR 12.4 / Mac OS 13.4.

 

Can you give more details of what's going wrong?  If there's an error message, please provide a full-resolution screenshot (not a phone pic).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

I have l already been through this as I described it earlier in this thread (on page 1), but the fix, which finally worked for me after repeated downloads of the plug-in, is not working now.  To be clear, I should be trying to install a folder with Lightroom Classic for Mac, not a single file. Correct? It is the folder I get when I download from the site.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

So you're seeing this? "I get this when I try to load the plug-in, including after doing the Control-right click thing on the Magick file: "An error occurred while attempting to load this plug-in.No other details."

 

Is that a pop-up message, or are you seeing it File > Plug-in Manager in the Plug-in Author Tools panel? If you're seeing it in the latter, click Save Diagnostic Log To File and then copy/paste the contents of that file here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

The pop-up message, as in what you quoted. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

After you dismiss the pop-up, go to File > Plug-in Manager, select the plugin, and look in the Author Tools panel.  If Save Diagnostic Log To File is ungreyed out, save it a file and copy/paste its contents here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

Tried as you suggest, and "no diagnostic messsages."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

Ok. It appears I have it fixed. Had to change the file name so it read LRMogrify2.plugin 
I was getting extra numbers after this filename, sometimes due to downloading mulitple times (as in LRMogrify2.plugin 5), but also because it sometimes downloaded as LRMogrify2.plugin 5.10

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

Glad you got it resolved.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 23, 2023 Oct 23, 2023

Copy link to clipboard

Copied

I tried the listed fix, and it does not work.

I am running Mac with Monterey.

 

I sent the developer an email last week. Hopefully, he will return my message,

If not, I will go back to doing borders through PS.

 

Thank you for this thread.

LR 13.1 Release, PS 25.2 Beta Release
iMac (Retina 5K, 27-inch, Late 2015), 4 GHz Intel Core i7, 64 GB 1867 MHz DDR3, AMD Radeon R9 M395X 4 GB

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 23, 2023 Oct 23, 2023

Copy link to clipboard

Copied

So this didn't work? I am using LR/Mogrify 2 with Monterey.

a. In Finder navigate to the folder where you placed the plugin.  

b. Right-click LRMogrify2.lrplugin and do Show Package Contents.

c. Open the subfolder  LRMogrify.extras.

d. Hold down the Ctrl key, right-click "magick", and do Open.

e. Confirm when it asks if you really want to open it.

f. Close the Terminal window that appears (ignore what it contains).

 

Now run the plugin.

If you get some error message, please show a screenshot.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2023 Nov 20, 2023

Copy link to clipboard

Copied

LATEST

Does not work. Images get exported without borders and text.

LR 13.1 Release, PS 25.2 Beta Release
iMac (Retina 5K, 27-inch, Late 2015), 4 GHz Intel Core i7, 64 GB 1867 MHz DDR3, AMD Radeon R9 M395X 4 GB

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines