• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

(Monterey) Metadata Field loses focus and triggers KBSCs

New Here ,
Jun 24, 2023 Jun 24, 2023

Copy link to clipboard

Copied

I am using Lightroom Classic 12.4 in MacOS 12.6.6.

 

Since one of the more recent updates of the MacOS version of Lightroom Classic I have been have been having an issue where I will be typing text into the Library metadata fields ("title", "caption", etc.) and it will suddenly trigger some sort of lightroom keyboard shortcut and take me to a "Develop" feature I didn't mean to invoke. This is super annoying! Most recently it caused the photo whose Metadata I was editing to be hidden or moved in the Library somehow so it no longer even shows up in Lightroom search. Again, this is super annoying.

 

Is there a way to disable keyboard shortcuts or at least could they not be invoked when the mouse or keyboard focus is on a Library Metadata field?

TOPICS
macOS

Views

673

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2023 Jun 24, 2023

Copy link to clipboard

Copied

There’s no way to disable the built-in keyboard shortcuts, but there shouldn’t be any need to…because what you’re seeing is not supposed to work that way. What it sounds like is something is causing keyboard focus to exit the text field, because the single-key shortcuts only apply when no text field has focus.

 

My Mac is also on macOS 12, and the reason I’m replying is that I’ve seen something similar. Maybe it isn’t the same as what you’re seeing, and I don’t know the exact cause, and it doesn’t happen all the time. But there have been times when I am typing in a Mac app and it starts beeping, and I realize it’s because something caused macOS to escape the text field.

 

I suspected it was some process that was in the background and decided to come to the foreground, and because it would keep happening and I had no idea which process it was, I would log out of macOS and log back in, and that would cure it for a while. (If that didn’t work, I would restart.)

 

Because it doesn’t happen all the time, and I haven’t seen it in a while, I am not sure if what I saw is related to your issue at all. But you should at least log out and back in, or restart the Mac, and see if that clears it up at least temporarily. (The point of logging out/restarting is to quit all user processes in case one is misbehaving.) If it continues to happen after that, try looking for any non-Apple software that’s running and has the potential to interrupt a foreground process. Especially the kind that lets you assign keyboard shortcuts or gestures that can be system-wide (overriding other applications).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey Conrad,

this failure happens onyl the very first time you enter the first letter of the new keyword. If you once accept this shortcut function of the first letter of the new keyword and  you go back into keyword section it will work until you restart LrC. Its absolutely ugly, but every new start of the application has that bug :-((( and it is still in version 13.01

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Mein System : Adobe LrC 12.5, MAC Pro with macOS 12.7

Fehler : Bei EIngabe von Stichwort nach dem Starten der Applikation, wird der erste Buchstabe des neuen Keywords als Tastenkurzbefehl interpretiert. z.B. Eingabe des Wortes Ford, wird das erste F als Vollbildanzeige interpretiert. Gehe ich danach in das Eingabefeld Stichwort, dann funktioniert die Eingabe, bis ich das Programm neu starte.

Fehler bekannt?

Wie ist die Abhilfe?

Liebe Grüsse aus Cadolzburg

Franz-Josef

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Moved from 'Bugs' to 'Discussions'. Even if this is a bug, you cannot file bug reports for outdated versions. BTW, there is no version 12.5...

And please do not double post, also not in two different languages.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey Johan, what kind of communication is this : It is a bug, and you can not file bug report

If it is a bug, and it is a big one for me, I will ever report this!!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Johan's information is correct.  Bugs are currently accepted against the current version only, which is 13.0.1. No further work is planned for any older version(s).  Please update to 13.0.1. If the bug is present in 13.0.1 it will be reconsidered. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey Rikk and is still in ver 13.01

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

My Sytem : LrC 12.5 MacPro wirg amcOS12.7

Problem : I start the application and always first letter of first Keyword I enter is translated into a short cut.f.e. keyword FORD creates instead of Keyword a full screen view. When accepting this and go back into window keywords, the application works. But difference is, that behind last entered keyword letter a symbol vertical ine is shown.

Hope my explaination is clear.

Failure cleared in version 13.

This failure has been not in all version before 12.5

Best regards from Franconia

Franz-Josef

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

There have been a couple other reports about this misbehavior in the last few months.

 

Moderators, @Rikk Flohr: Photography, please merge with this thread:

https://community.adobe.com/t5/lightroom-classic-discussions/keyboard-shortcuts/m-p/13890090

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Problem: Ever since I installed LR 13 sometimes when I am trying to Keyword photos in the Library module, if the word has an "o" in it, the People view comes on and starts looking for People in my images. I've been using Lightroom Classic since v. 6 and this has never happened before. What's more, I can't turn it off, neither by going to View Menu: People and clicking on it to try to clear the checkmark, nor by hitting the "o" key. Both the behavior during entering keywords and the inability to turn it off seem to be a bug. 

 

Expected results: 1. Entering keywords will not result in keyboard commands being executed instead of keywords being entered. 2. If People comes on, typing "o" or clearing the checkmark should turn it off.

 

App version: LR 13 Classic

Mac OS 12.7 Monterey

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 04, 2023 Nov 04, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 05, 2023 Nov 05, 2023

Copy link to clipboard

Copied

Hey Helen,

click again on the face symbol in the lower line of the screen and people view will turn off.

The reason why you get the function people view by typing "o" for a keyword is the mistake in LrC. to go arround the failure, you have to once go out of the keyword section. And this failure happens only the first time after start when you enter to the keyword section

Hope its clear and it will work 

Bildschirmfoto 2023-11-05 um 15.43.37.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2023 Nov 05, 2023

Copy link to clipboard

Copied

Thanks for your offer to help, but I don't see a face symbol anywhere in the interface even when People Finder is active. The only way I can clear it is to hit the "g" key which resets it to Grid View. This is true whether I turn it on accidentally or deliberately.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey have you checked vers 13.01. From my point of view bug is still in.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2023 Oct 30, 2023

Copy link to clipboard

Copied

When starting to type in the title or caption field, after typing one character the keyboard focus is lost and keystrokes start getting interpreted as shortcut commands doing god-knows-what.  This behavior is frequent, but does not happen every time either.  This is new behavior that started recently, in the last 4 months or so.

 

Needless to say, this makes adding metadata to photos very difficult.  Combined with the bug that the title or caption field gets truncated and is not entirely displayed, a bug that was reported by multiple people years ago and has yet to be fixed, and Lightroom is becoming unusable as a photo cataloging tool.

 

Lightroom Classic 13.0.1 [ 202310121438-d2af310c ], MacOS 12.7.1.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

There have been a couple other reports about this misbehavior in the last few months.

 

Moderators, @Rikk Flohr: Photography, please merge with this thread:

https://community.adobe.com/t5/lightroom-classic-discussions/keyboard-shortcuts/m-p/13890090

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

I have made a simple help on my screen : a sticker that says : ATTENTION first keyword entry will create a shortcut

After that keyword operation works till the next restart 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

I am unable to replicate this failure with the instructions given.  
Mac 13.5.2
LrC 13.0.1 

Better instructions and system information are needed for consistent replication. Can anyone in this thread supply those?

 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Very simple : Restart LrC - go to keyword field - enter the first letter - f.e. F and your actual picture is shown as full screen view instead of F as first letter of new keyword for picture And ATTENTION Failure happens only after restart for the first keyword letter !! Additional info : I have checked and shown this two days ago on phone and remote screen with the helpdesk in India

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Working fine here:  

Screenshot 2023-11-02 at 4.46.47 PM.png


I am still not able to replicate the issue.  

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

did you restart LrC with a complete closure of application?

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Twice - worked as expected both times…

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

please give me 60 min and I will come back, to check for other hints.

My system checks have been a ) MACPro with 11.7 and LrC 12.5 and MacPro with 13.x and LrC 12.5 and 13.01  and MAC Book Pro with 11.7 and LrC 12.5

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey Rikk,

here I am back, try with a Komma as first character.

the firsttime after restt of LrC will show you no optional keywords Like picture below

Bildschirmfoto 2023-11-02 um 23.52.32.png

 if you do it again after second time in keywords, system expects a new keyword and gives you some option like in picture below

Bildschirmfoto 2023-11-02 um 23.51.28.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines