Select Subject in Lightroom classic taking a long time to load

New Here ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Hi all, i am currently using Adobe lightroom classic, the select subject tool is taking a long time (a minute or 2, to select the subject). It just started recently, have updated all my drivers (using Dell - Windows) but issue continues. Please help!

TOPICS
Windows

Views

304

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out. We're sorry for the trouble with Lightroom Classic. I'd love to help you figure this out.

 

Could you please share the specific version of Lightroom & the operating system you are working on? Does the select subject work slowly with a specific set or range of files? What type of images do you work with? RAW or JPEG?

Have you tried any troubleshooting steps?

 

Try to reset the GPU caches by following these steps.

Please go to the following locations

  • C:\Users\<Username>\AppData\Roaming\Adobe\CameraRaw
  • Press the Windows > Enter 'Run' > Type %appdata%\Adobe\CameraRaw > Hit OK
  • Rename the GPU folder as 'GPU.old' (add .old at the end)
  • Restart Lightroom Classic again

 

If this does not help, try this suggestion and let us know if selections work better.

  • Go to Lightroom > Preferences > Performance > Use Graphics Processor > Set it to OFF if it is on Custom or Auto.

 

Let us know how it goes,

Thanks!
Sameer K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Hi, Thank you for you reply.

Here is a copy of the sytem info. (pls see attached)

Press the Windows > Enter 'Run' > Type %appdata%\Adobe\CameraRaw > Hit OK

Please explain this above line, not understanding.

Thank you!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Hi. I tried both steps you suggested, neither worked. I am using Raw files

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Note that Select Subject/Sky doesn't obey the setting Preferences > Performance > Use Graphics Process (it should but doesn't).  So changing it won't have any effect on your problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Thank you.
Any other ideas....
It's very frustrating.
Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

You could try rolling back your graphics driver to something from six months or a year ago.  A couple have reported (with other brand GPUs) that worked around problems with Select Subject/Sky. You could be tripping over problems recently introduced into the Intel driver.

 

The general issue is that LR relies on the correctly-operating graphics drivers, and drivers have bugs and performance issues (which is why the manufacturers release new versions frequently).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Brilliant! It worked! Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

LATEST

Unfortunately it stopped workinging altogether when rolled back...

I get a message of "sorry we can not complete your request - error" when using the select tool.

Please help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines