• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Upgrading Mac OS (old) and Lightroom (old)

Community Beginner ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

I am using Lightroom 5.7 and my current Mac OS is 10.14.6. I am going to upgrade to OS 14 (Sonoma) and know I will need to upgrade Lightroom, too. (Yes, I am way behind.) How do I make so upgrades without losing my current cataloging? Thanks for any advice.

TOPICS
macOS

Views

183

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Make sure your Mac meets the Lightroom Classic system requirements.   https://helpx.adobe.com/lightroom-classic/system-requirements.html

 

The current version of Lightroom Classic will see the old catalog, read it and make a new catalog.  The old catalog and old version won't be replaced.  Once you are in the new version, any new editing changes will only work in the new version.    Be sure you have data backups in case there are any surprises!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Thanks for the information. Time for a leap of faith (after backing it up).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Be aware that BIll Sprague is talking about Lightroom-CLASSIC which is the upgrade from v5.7.. (Not "Lightroom"),

Lightroom-Classic is only available in the Photography Plan 20GB.  (Not the Lightroom Plan)

@ BUY PHOTOGRAPHY PLANS

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2024 Apr 25, 2024

Copy link to clipboard

Copied

Thanks for the info. That's the plan I'm looking at.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Let's be clear your Lightroom 5.7 is a catalog model with your image files stored on your local disks?? Rather than the Cloud storage based Lightroom?? How old is it??

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2024 Apr 25, 2024

Copy link to clipboard

Copied

Yes, the photos are stored on local disks. Unsure exactly how old it is, but 5.7 was the latest version when I purchased it. Is there anything I should be aware of since the photos are stored locally?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 25, 2024 Apr 25, 2024

Copy link to clipboard

Copied

It really is simple (if you know how 🙂  ), but be aware of-

1) Your v5.7 Catalog name and the folder in your system where it is stored.

2) You have a backup of the catalog on another physical drive.

 

Then the process is to-

1) Install the Creative Cloud Desktop App (This controls your subscription and any installs of apps)

2) Use the Desktop App to Install Lightroom-Classic

3) Start (Open) Lightroom-Classic.

 

If LrC opens with an empty catalog (no photos) then it has started a new catalog, so then-

1) Close Lightroom-Classic

2) Find your v5.7 Catalog in Finder (You should be aware of this now)

3) [Double-Click] the catalog .LRCAT file.   ([Double-click] is a way of starting any .LRCAT catalog file.)

4) Agree to upgrade the catalog (v5.7 > v13) as suggested by @Bill Sprague in his early post.

5) Set the Lightroom-Classic PREFERENCES to 'Always open' this upgraded (-v13 ) catalog.

 

(Any unwanted empty Catalog can be deleted when your v13 catalog is running successfully.)

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2024 Apr 26, 2024

Copy link to clipboard

Copied

Great information. Thanks. (I know where the .LRCAT file is and have the folder backed up a couple of ways.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 25, 2024 Apr 25, 2024

Copy link to clipboard

Copied

quote

my current Mac OS is 10.14.6. I am going to upgrade to OS 14 (Sonoma)

By @johnr300

 

Just going back a step, are you upgrading your existing Mac or buying a new one?

 

If you're upgrading, have you checked that your Mac is compatible with Sonoma?

macOS Sonoma is compatible with these computers - Apple Support

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2024 Apr 26, 2024

Copy link to clipboard

Copied

LATEST

Thanks. It is compatable (and Sonoma was installed successfully).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines