• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

P: Export Catalogs with backward compatibility to previous LrC versions

Community Beginner ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

Hola, Me gustaria recomendarles que pongan la opcion de exportar catalogos con compatibilidad en versiones anteriores, como lo tiene Illustrator, ya que los profesionales de la fotografia compartimos catalogos con otros colegas, y no todos tienen los programas actualizados, ya que las PC no son lo suficientemente pontentes como para soportar las ultimas versiones de Lightroom, es mas, desde que actualice mis programas a las ultimas versiones, fue de mal en peor su funcionamiento, hasta el punto tal de que hoy ni siquiera puedo editar, pero me encuentro con el problema de que no puedo volver a utilizar versiones anteriores ya que tengo decenas de catalogos hechos con la ultima version de Lightroom, y no se dan una idea del perjuicio que esto me ocasiona. Gracias!

Idea No status
TOPICS
macOS , Windows

Views

172

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
5 Comments
LEGEND ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

Moderators, @Rikk Flohr: Photography, please move to Ideas.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

English translation of original post

 

"Hello, I would like to recommend that you put the option to export catalogs with compatibility in previous versions, as Illustrator has, since photography professionals share catalogs with other colleagues, and not everyone has updated programs, since PCs are not powerful enough to support the latest versions of Lightroom, Moreover, since I updated my programs to the latest versions, it went from bad to worse its operation, to the point that today I can not even edit, but I find the problem that I can not use previous versions since I have dozens of catalogs made with the latest version of Lightroom, And they have no idea of the damage this does to me. Thank you!"

 

 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

You would need to keep in mind that many edits could not be handled in the older versions. Also what the internal Camera RAW supports. As such, you would need to limit your edits to those available in older versions. And your sources.  Items such as:

 

Cameras supported

Profiles used 

Process used

AI anything

Masks

Content Aware Remove

Mapping

Facial rec

Presets in use

Plug-ins in use

Presets and plug-in locations

Enhance

Color Grading

Hue adjust

etc

 

Also, each upgrade (upgrade not update) involves a new version of the database engine. So you would need a copy of each Lr version on your computer, or LrC would need to have a copy of each SQLite version written in the code, agggh that would make the app much larger, not going to happen.

 

In short, no.

 

 

 

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 14, 2023 Jan 14, 2023

Copy link to clipboard

Copied

I have to agree with @GoldingD . The fact that you will lose edits that were not supported in the previous version is one thing, but you will also see unsupported images from cameras that were not yet supported. The potential mess you create with it would not be worth it.

 

If you really need to go back for some reason, then do the following. Select all images and choose the menu 'Metadata - Save Metadata to Files'. Then create a new catalog in the older version of Lightroom Classic and import these images. You obviously won't get everything back into an older catalog this way, but those edits that were already supported will be applied and all keywords will be applied too, so this is a workable solution.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 14, 2023 Jan 14, 2023

Copy link to clipboard

Copied

LATEST

Hola! muchas gracias por el consejo! lo seguire!

Votes

Translate

Translate

Report

Report