Lightroom keeps crashing!

Community Beginner ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

First time poster here... has anyone else had problems with LR crashing their IMac? I am working on a 8 month old IMac and it crashes when I'm using LR heavily. I updated LR a few days ago and the problem seems worse. Just now I was in LR editing and it crashed 5 times within an hour!! You can imagine how frustrating this is. I am using no other program when it does this. Today it repeatedly happened when I was using the spot healing tool. Any help is appreciated! 

TOPICS
Crash or freeze, Mac

Views

2.5K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

I'm on a 2017 iMac and Lightroom (version 9.4) crashed constantly for me.  Mostly when creating large amounts of standard and/or smart previews.  

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

The first thing that you should try is to switch off the GPU support from the Lightroom preferences and check if that helps to fix the issue. 

Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor" > Restart Lightroom. 

https://helpx.adobe.com/lightroom-classic/kb/lightroom-gpu-faq.html#troubleshooting 

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html 

 

If Lightroom doesn't start correctly the please see "Solution 2" in the document behind the second link. 

 

Another step is to try to reset the Lightroom preferences. 

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/ 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Thanks Axel! I did switch off GPU support last night and was able to do an hour's worth of work with no issues, which hasn't happened since the LrC update, so thank you for the suggestion! I am wondering though, is this a permanent solution or is it best to figure out the actual issue and continue to use GPU support in LrC? Thanks again! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Many thanks as well from me, Axel. As you suggested, with unchecked "Use Graphic Processor" the last 30 minutes without crash..

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

This is also happening with me - on a 2019 iMac.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

So frustrating! Try turning off your GPU support like Axel suggested above. It seemed to work for me last night. Hopefully these pros can help us figure out a permanent solution! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Ok, so we have three, relatively new, users in this thread all using iMacs released within the last few years apparently having various issues causing problems. Just so you are all aware this is a user to user forum so the responses you receive will be from users like yourself. We need specific info on your operating system and more details of what functions you are attempting when your problem occurs.

Is your LrC app crashing or the OS crashing? Any info that can help us in identifying your problem.

See the screen capture which indicates the things that are important from the forum guidelines when creating a new thread.

Also, please indicate if any of the links provided by Axel have been helpful?

 Forum-guidelines.png

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.2.3, LrC 10.2, Lr 4.1, Ps 22.3, Pr 14.8.0; Camera OM-D E-M1.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

I will get my computer info to you when I get back home this afternoon. I almost always "Report the problem" when it crashes but I'm not sure what's done with those reports. I did turn off the GPU in LrC preferences as Axel Matt suggested and was able to do over an hour's work last night with no issues (thank you!!). I want to know though, is this a permanent solution or is it still ideal to have GPU support in use with Lr?

When it happens, my entire OS crashes, not just the LrC app. 

As far as specific functions, it tends to be when using an adjustment brush or the spot healing tool.  Thanks for the help! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Please post your System Information as Lightroom Classic (LrC) reports it. In LrC click on Help, then System Info, then Copy. Paste that information into a reply. Please present all information from first line down to and including Plug-in Info. Info after Plug-in info can be cut as that is just so much dead space to us non-Techs.

 

GoldingD_0-1603824672329.jpeg

 

GoldingD_1-1603824672330.png

 

 

GoldingD_2-1603824672330.png

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

I hope this is what you're looking for! 

 

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.15.7 [19H2]
Application architecture: x64
Logical processor count: 6
Processor speed: 3.1 GHz
SqLite Version: 3.30.1
Built-in memory: 8,192.0 MB
Real memory available to Lightroom: 8,192.0 MB
Real memory used by Lightroom: 880.0 MB (10.7%)
Virtual memory used by Lightroom: 12,283.1 MB
Memory cache size: 273.7MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1982MB / 4095MB (48%)
Camera Raw real memory: 2409MB / 8192MB (29%)
Displays: 1) 5120x2880

Graphics Processor Info:
Metal: AMD Radeon Pro 575X

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/My Book/1-Lightroom/Backups/2020-01-04 0712/Lightroom Catalog-2-v10.lrcat
Settings Folder: /Users/jennpoth/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) Nikon Tether Plugin

Config.lua flags: None

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

hey Jenn, sounds familiar!

since last LR update editing pictures is no longer possible without constantly freezing my mac, too. While still working everything goes only in extreeme slowmo and usually it takes only a couple of editing procedures before evenrything freezes up. Then the only way to get going again is to shut the computer down.

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Yes it's terribly frustrating! I have had luck turning off the GPU support but I'm wondering if this is a permanent fix and should I ideally have GPU support running, so is there a better solution? I have to get my system info to the repliers above and see if there is anything better to do. But at least I am back up and running without interruption for the time being! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

I've got the same problem!! It's crashing every 5 minutes... I'm not even getting work done- soooo frustrating!! But it seems to happend whem i'm using a preset, which is also weird 'cause that didn't happend before.. So that could not be the problem??

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Ok, multiple MAC  users with a common issue

 

You all need to let Adobe know this.

 

Not in this community site, but at a site Adobe Techs actually watch

 

That is the official Adobe feedback site. Specifically fir LrC Problems.

 

Post at: https://feedback.photoshop.com/topics/lightroom-classic/5f5f2093785c1f1e6cc40872?cType=PROBLEM&page=...

 

Include your System Info as shown above (my earlier reply)

 

And reply in this community page discussion, the link to your posting.

 

And yes, you can add yourself to another members posting if you want

 

PLEASE PLEASE let ADOBE KNOW

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

So frustrating... I looked at several forum pages, and all with different solutions to prevent LrC from crashing. But it keeps on doing so...! A short list of 'possible suggestions' found on the internet:

  1. Make Sure You're Running the Latest Version of Lightroom.
  2. Optimize the Catalog.
  3. Turn off the GPU.
  4. Reset the Preferences.
  5. Try a New Catalog.
  6. Uninstall, Reboot, and Reinstall.
  7. Check for Operating System and Hardware Problems.
  8. Make Sure You Don't Have Any Corrupted Presets or Fonts.

Well, I do have the latest version, I did try several options, reset preferences, new catalog, etc, etc. But I'm paying for this... Why should I change default settings to prevent a bought program from crashing. Adobe is a large company, and if LrC works I am very pleased with it. But since latest Windows updates and also LrC updates, it becomes almost unworkable. For me it is time to look for alternatieves like Darktable or others.

I would not be proud on this if it was a product I had to sell... I would (as company) do everything to prevent losing customers....
I....said already enough!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

Yes, I'm getting lots of Lightroom Classic crashing. It freezes, sometimes the cursor disappears, then I get the beach ball and eventually the computer shuts down and on restart says that "something went wrong and it had to restart." It seems to happen whenever I'm working in Develop mode, but has also frozen right after a restart. I uninstalled and reinstalled four times two days ago. Yestderday I upgroaded to Mac OS to Big Sur and today I installed Lightroom Classic 10.1. LRC worked in Library mode and I was able to do several Auto tone adjustments in Develop, but then it froze up. I'm using a 2016 iMac with 32GB Ram. Here is the report (although this is from the app after restart).

Lightroom Classic version: 10.1 [ 202012012023-e92d50bb ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.16.0 [20C69]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.2 GHz
SqLite Version: 3.30.1
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 1,510.0 MB (4.6%)
Virtual memory used by Lightroom: 8,664.2 MB
Memory cache size: 97.7MB
Internal Camera Raw version: 13.1 [ 658 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 141MB / 16383MB (0%)
Camera Raw real memory: 189MB / 32768MB (0%)
Displays: 1) 5120x2880

Graphics Processor Info:
Metal: AMD Radeon R9 M380

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Users/duanecraig/Documents/PixCatalog/August 2020/August 2020-v10.lrcat
Settings Folder: /Users/duanecraig/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) Nikon Tether Plugin
6) ON1 Resize Standalone 2020

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x64
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon R9 M380 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-4.2.13
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

Same for me: monitor freeze, cursor disappears, iMac restarts (with the message something went wrong)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

I'm experiencing the same problem though on a P.C.

When in Slideshow after uplaoding music, I can't seem to use the mouse than Lightroom just shut's itself down.

Now I cannot open lightroom folder I was working in, as it says it is already open(there is no programs open on my computer??)

Any suggestions would be great,

Merry Chraistmas.

S.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 22, 2020 Dec 22, 2020

Copy link to clipboard

Copied

Hi, I already reported my problems with crashing LrC. Shame on Adobe to dare sell this product...
But wrt your problem: LrC creates a lock file (<catalog name>.lock) in the same location as your library.

It is wise not to remove that, but if LrC crashed I think you can delete that file and start LrC again.
I removed that several times after crashes... But crashes will remain.
On advice I optimized my catalog too and that seems to help a bit, but crashes will remain.

Earlier I also did a remove and re-install, helpt shortly, but crashes will remain....

 

Let's hope new year wil be a good new year for all LrC users...

Succes, Dick

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

Saa as me problem for me although fine on I phone and I pad. Needs addressing. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2021 Jan 02, 2021

Copy link to clipboard

Copied

Yesterday, I was having the same problem on my iMac late 2014. My computer froze while using the (LRC) radial tool. I rebooted several times. At first, I thought it was because I had just installed the Topaz software but now I am convinced it is LRC. Anyway, today I thought I'd make another attempt. This time it froze and then shut off completely. I have not been able to boot it up at all now. Totally dead. I can't even get to the GPU if I wanted to. Not a good way to start the new year!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

Yes it's happening to me also. Creating so many issues. If it's not restarting my Mac it's freezing it completely. Exporting images well that crashes it as well. I can't run a business like this. It's taking me over an hour just to export 6 images 🤦🏼‍:female_sign:

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

What worked for me, Mandy, was to turn off the GPU Acceleration in Preferences. A month or so went by and after a few more Mac OS updates I turned GPU acceleration back on and things are working fine. My initial issue happened after I upgraded to Big Sur and shortly before that I had upgraded to a higher level of LRC. So, in my case I think it was a clash between the different upgrades which time took care of. Hope it helps!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines