• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Apple M1 Ultra stuck with "Limited graphics acceleration"

Explorer ,
Jul 01, 2022 Jul 01, 2022

Copy link to clipboard

Copied

I have a brand new M1 Ultra with 64GB RAM, 20 cores, 48 GPU Cores.
Yet LightRoom still will not support anythig beyond "Limited graphics acceleration".
When Use Graphics proceesor is set to Auto, this is all it says.
When I change to Custom, I see "Use GPU for Display" is checkmarked.
The other two options; Use GPU for image processing and Use GPU for exportt are greyed out.

From timed tests before and after the recent update with GPU accelerated export, I notice no difference in time to export 1000 images.  Both ran within a few seconds of each other.

It seem other Apple M1 users have these options. How do I get them turned on?

I called Adobe support, but I hate to say, Adobe simply does not know anything about their own products.
I tear my hair out every time I have to call them.

Hopefully someone here will have some helpful information.
Thanks!

TOPICS
macOS

Views

265

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jul 01, 2022 Jul 01, 2022

Got a lot of help from another website.  No answers but confirmation that other people had this working, so it had to be something on my end.
I had tried clearing preferences. I even tried full uninstall with removal of preferences. No luck.
So with a bit of running down rabbit holes I found the issue... 

So, some sort of legacy files left behind in my User’s “Library/Application Support/Adobe/Lightroom/Preferences/” folder,

  • Lightroom 6 Startup Preferences.agprefs
  • Lightroom Classic CC 7 Startup Prefe
...

Likes

Translate

Translate
Explorer ,
Jul 01, 2022 Jul 01, 2022

Copy link to clipboard

Copied

Got a lot of help from another website.  No answers but confirmation that other people had this working, so it had to be something on my end.
I had tried clearing preferences. I even tried full uninstall with removal of preferences. No luck.
So with a bit of running down rabbit holes I found the issue... 

So, some sort of legacy files left behind in my User’s “Library/Application Support/Adobe/Lightroom/Preferences/” folder,

  • Lightroom 6 Startup Preferences.agprefs
  • Lightroom Classic CC 7 Startup Preferences.agprefs

They only contained information about upgrades from various versions of LRCat 3, 4, 5, and 6 along with various imported catalog info. NOTHING that would seem to indicate control of GPU or other rendering issues.

I deleted both, restarted LightRoom, and BAM! FIXED!


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

What was the "other website" where you received help? Updating to version 12.0 has borked my M1 Max GPU support, and this solution isn't working for me. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Cameron, quit Lightroom then try going to /Users/[user name]/Library/Application Support/Adobe/CameraRaw/GPU/Adobe Lightroom/

and then delete the Camera Raw GPU Config.txt Then restart Lightroom and see if that's done the trick.

-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

LATEST

This did the trick! Believe it or not, I found this solution about 3 minutes ago on a different obscure Google result, and things are back to running correctly. Thank you for your reply!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines