Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom error, Could not run script: LibraryFactory.lua

New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Good day

My lightroom has a sudden error and now I cant use it. please see the below error notification:

Anyone able to assist please?

Could not run script: LibraryFactory.lua
Error: module 'LibraryFacesGridRendering' not found:
no field package.preload['LibraryFacesGridRendering']
no file '.\LibraryFacesGridRendering.dll'
no file 'C:\Program Files\Adobe\Adobe Lightroom\LibraryFacesGridRendering.dll'
no file 'C:\Program Files\Adobe\Adobe Lightroom\loadall.dll'

TOPICS
Problem or error

Views

93

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry that you're getting an error message while using Lightroom Desktop that says "Could not run script: LibraryFactory.lua".

 

You will see this message if you have a bad installation. 
  • Try resetting the Lightroom app preferences to default? Press and hold the Shift + Option + Delete keys.(Mac) or Press and hold the Shift + Alt keys while
    starting Lightroom. A dialog box should appear asking you restore the preferences. Check if that helps. If not, check the next steps.
  • Uninstall Lightroom CC via the Adobe Creative Cloud Application
  • Restart your computer. 
  • Use the Adobe Creative Cloud Application to reinstall Lightroom CC. 

 

Let us know if that helps.

 

Thanks,

Akash

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

Thanks for the feedback.

 

I tried the below but no luck.

I unistalled lightroom, but now I can't re install it as my laptop doesn't match the system requirements.?

 

Kind regards 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

LATEST

My conclusions in this forum thread are this-

1) "Lightroom" was a perpetual Version (Version 6) for which Face Recognition ceased because of an 'expired' dll file.

2) The OP has a Mac with Catalina or BigSur 64bit OS that cannot install 'old' 32bit software.

 

 

Regards. My System: Lr-Classic 10.4, Photoshop 22.5, Lightroom 4.4, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines