Lightroom error, Could not run script: LibraryFactory.lua

New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Good day

My lightroom has a sudden error and now I cant use it. please see the below error notification:

Anyone able to assist please?

Could not run script: LibraryFactory.lua
Error: module 'LibraryFacesGridRendering' not found:
no field package.preload['LibraryFacesGridRendering']
no file '.\LibraryFacesGridRendering.dll'
no file 'C:\Program Files\Adobe\Adobe Lightroom\LibraryFacesGridRendering.dll'
no file 'C:\Program Files\Adobe\Adobe Lightroom\loadall.dll'

TOPICS
Problem or error

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

LATEST

Hi there,

 

Sorry that you're getting an error message while using Lightroom Desktop that says "Could not run script: LibraryFactory.lua".

 

You will see this message if you have a bad installation. 
  • Try resetting the Lightroom app preferences to default? Press and hold the Shift + Option + Delete keys.(Mac) or Press and hold the Shift + Alt keys while
    starting Lightroom. A dialog box should appear asking you restore the preferences. Check if that helps. If not, check the next steps.
  • Uninstall Lightroom CC via the Adobe Creative Cloud Application
  • Restart your computer. 
  • Use the Adobe Creative Cloud Application to reinstall Lightroom CC. 

 

Let us know if that helps.

 

Thanks,

Akash

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines