P: Alpha channel not rendering correctly in smart objects - crosshatching/translucent glitches

2 Votes
Explorer ,
Sep 16, 2016 Sep 16, 2016

Copy link to clipboard

Copied

I use smart objects all the time, and as of recently, I've been noticing problems with how they render. 
See the image here http://i.imgur.com/fzbzs9q.png

This is a PSD file placed into another PSD (as an external smart object). You can see the dotted pattern that occurs in it. If you look at the extra-zoomed pic on the left, you can make out that some of the pixels are actually translucent (you can see Photoshop's checkered pattern underneath them).

That's the problem - not all pixels are rendered as 100% opaque, even though the pixels in the source image are opaque. And the ones that are rendered as translucent are done so in some sort of pattern, resulting in these visual artifacts. If I create a layer of solid color underneath the smart object, the problem is no longer visible. 

I'm not sure what this problem is caused by. It might be something I'm doing wrong, though I can't think of anything new in my routine to have caused it (and I've used smart objects for years). Perhaps it's something to do with one of the more recent updates. I've also noticed that it seems to only happen at 16bit and 32bit modes. 

Here's another example - this time from an embedded smart object. Notice the irregular crosshatching on the buildings: http://i.imgur.com/npkhsy0.png

Bug Fixed
TOPICS
macOS , Windows

Views

51

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 02, 2016 Nov 02, 2016

Votes

Translate

Translate
8 Comments
Adobe Community Professional ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

Could you post a layered file for testing? 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

Agree with Christoph, a source PSD could help us better troubleshoot.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 18, 2016 Sep 18, 2016

Copy link to clipboard

Copied

Sure. Here you go. Some notes and info for context are inside the PSB

http://www.filedropper.com/pssmartobjectcrosshatching

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Sep 18, 2016 Sep 18, 2016

Copy link to clipboard

Copied

I get a similar result on Mac 10.11.5, but it seems dependent in the »Use Graphics Processor« Preferences setting. 

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 19, 2016 Sep 19, 2016

Copy link to clipboard

Copied

ok, well I guess that rules out it being an nvidia driver problem, since it happens on both Mac and PC.

It appears to happen in Normal and Advanced GPU mode, but not Basic. 

Is this something you can fix?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 19, 2016 Sep 19, 2016

Copy link to clipboard

Copied

Looking into it. Also doesn't happen if the document is in 8-bit, rather than 16-bit.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 19, 2016 Sep 19, 2016

Copy link to clipboard

Copied

Yes, I mentioned that in my original post. Unfortunately, the choice then often becomes "which artifacts do I want? color banding from 8bit, or crosshatching from the bug?" 😕

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 02, 2016 Nov 02, 2016

Copy link to clipboard

Copied

LATEST
This should render more consistently in CC 2017: http://blogs.adobe.com/photoshop/2016/11/keep-creating-a-guided-tour-through-the-latest-photoshop-up...

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report