• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

P: Alt key shorcut, menu activating and beeping

17 Votes
LEGEND ,
Aug 18, 2011 Aug 18, 2011

Copy link to clipboard

Copied

The Alt key activates the menu. This new behaviour in CS5 is driving me nuts. When you try to zoom with the mouse wheel and Alt if you don't press ESC or Alt again you are confronted with annoying beeping. And let's say use a shortcut like Ctrl+Alt is fine but if you press it the other way Alt+Ctrl again activates the menu. This was not the case in previous version of PS, it woulb be nice if this is fixed.

Bug Fixed
TOPICS
Windows

Views

39

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 19, 2017 Oct 19, 2017
This issue should be fixed in the latest release of Photoshop CC: https://blogs.adobe.com/photoshop/2017/10/get-the-goods-announcing-updates-to-photoshop-cc-dimension...

Votes

Translate

Translate
86 Comments
Aug 18, 2011 Aug 18, 2011

Copy link to clipboard

Copied

Hi,

Would you mind providing additional information?

What menu is being activated with the alt key?

What type of operating system are you using? Have you updated to the latest version of CS5, 12.0.4?

Thanks.

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 05, 2012 May 05, 2012

Copy link to clipboard

Copied

I can reproduce the problem 100%

1) Open PS and press CTRL+ALT at the same time repeatedly, you'll notice the menu bar gets activated almost every time you do it (as if you were pressing only ALT).

2) Do the same with Notepad, you'll notice that the behavior is different from PS, because there has to be certain timeout between key presses in order to activate the menu bar.

What this does in PS is to activate the menu bar if you don't hit the keys in the right sequence (the wrong one would be ALT+CTRL, the good one CTRL+ALT, the random one would be pressing both keys at once).

Therefore activating the menu bar and making the "Default beep" to sound (for example when using another keyboard shortcut) and of course with the inconvenience of having to hit ESC or ALT to restore the focus back to your active image area.

BTW There's a known issue with ALT+SCROLL_WHEEL http://forums.adobe.com/message/4082562

CS5*, W7

Votes

Translate

Translate

Report

Report
New Here ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

Same problem here. Very annoying, I use Alt+Scrollwheel to zoom and Alt with clone related tools (as it's default key for getting pixels to clone).

I'm surprised Adobe haven't done anything about for quite some time. I guess users should be more vocal... wait, they did complain numerous times in the forums, but apparently nobody saw those posts: https://www.google.pl/search?q=alt+ke... (look at first result - forums.adobe.com)

Anyway, Ps 12.0.4.

Votes

Translate

Translate

Report

Report
Jan 10, 2013 Jan 10, 2013

Copy link to clipboard

Copied

Hi,

I tried with both CS5 (12.0.5) and CS6 on Windows 7 (64-bit) and I can't reproduce this beeping/menu problem.

Would you mind letting me know your machine configuration and specific steps to repro just to make sure I get it right?

Also, have you tried updating to 12.0.5?

Thanks.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 10, 2013 Jan 10, 2013

Copy link to clipboard

Copied

Glad to know you're interested in helping Micheal.

Windows 7 (64-bit) SP 1. I've got Ps 12.0.4. Polish version.

Just use Alt with scroll wheel or with click (its default setting for stamp tool) and you get menu highlighted. Release alt and menu still has focus. Try to use keyboard shortcut and you get beep. Same problems occurs in Ai. If you have any more questions you can ask in forum. For example here http://forums.adobe.com/message/3092204

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 21, 2014 Oct 21, 2014

Copy link to clipboard

Copied

I know, I know... 3 years old post, but someone stil end up here (as I did...).
So, here's the solution: http://millionart.deviantart.com/art/...

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 21, 2014 Oct 21, 2014

Copy link to clipboard

Copied

So removing that panel/plugin solves the problem?

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 11, 2015 Jan 11, 2015

Copy link to clipboard

Copied

No... This third party software solves your bug. It is so widespread and annoying that someone took the trouble it to make a program that will fix it. And did not wait for it until you fix it.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 11, 2015 Jan 11, 2015

Copy link to clipboard

Copied

I made a video where it is perhaps seen. http://youtu.be/7S0YD7s9vK4

1) I made selection
2) Zoom in by Alt + Scroll
3) Deselection by Ctrl + D doesn't works
4) I must click on the menu or again pres Alt key

5) Zoom out by Alt + Scroll
6) I want change "select tool" to "move tool" by pressing "V"
7) Fail - Layers menu open
8) I must click on the menu or again pres Alt key
9) Press "V" again

It's NOT only a problem of zoom. This is an example where this may occur.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 11, 2015 Jan 11, 2015

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 23, 2015 Mar 23, 2015

Copy link to clipboard

Copied

I have this same problem as Jaroslav. I have to hit ESC constantly after zooming or using ALT key with most tools. There needs to be a "disable ALT Menu" option without having to install a third party tool. I am using up to date version of CC on Windows 7.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 05, 2015 Aug 05, 2015

Copy link to clipboard

Copied

In erlier versions of photoshop i solved this problem by instaling Photoshop Assistant (http://millionart.deviantart.com/art/...) - its checkbox there which turn off alt function (only for quick access to header menu, all other alt functions still working )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

Quite disappointing to find this bug has been known for half a decade and is still annoying Windows users.

As a remedy, I've enabled "Zoom with Scroll Wheel" and I'm using the temporary hand tool (Space bar) to navigate around a document. If this option is enabled, Alt+Wheel will scroll the document vertically, and you'll find the exact same bug there, however the space bar is sufficient for me to get around the document, so the bug causes a lot less pain.

RackMultipart201603299119714hx-414eb23b-f77c-4612-aff1-e5be6661f4bd-579816842.png

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

Can we make a bet? I bet 10 dollars that it will not be fixed in the next 5 years since now.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

I've asked our eng team to investigate.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

Please add "magic" checkbox: "Don't activate menu by Alt key" in preferences and make it default. Or look in your data from anonymous statistics how much users use this for work and then decide default value.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

@jaroslav: Accessing the menu using the Alt key is standard Windows user experience. Disabling that would be throwing out the baby with the bathwater. I would expect Photoshop to simply handle the Alt key correctly depending on context, without having to forfeit quick menu access via shortcuts.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

It would be the optimal solution, but I do not believe that programmers can handle it. I would expect that it will be buggy and fix will not cover every case of occurency. Not because they are bad programmers, but because Photoshop is very complex. Therefore, I would rather have a bulletproof fix 🙂 In addition... checkbox would be optional and would operate only for the top menu.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 30, 2016 Mar 30, 2016

Copy link to clipboard

Copied

as i sad before.... that chinese plugin PS assistant handle this behavior.... alt stopped beeping and header menu was still accesible through alt shortcuts, so its possible to make it like that 🙂 

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 30, 2016 Mar 30, 2016

Copy link to clipboard

Copied

you are right... Photoshop with plugin is waiting for second key e.g."alt+f". Alt key itself without second key does nothing.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 30, 2016 Mar 30, 2016

Copy link to clipboard

Copied

But this plugin was sometimes a bit buggy. In this case I need restart plugin. But it's relative rare.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

Yup the menu activation and beeping drives me insane.  Makes using the Photoshop shortcuts incredibly annoying.  I retouch for a living so I'm dealing with this daily.  Hate it and a fix would be good.  How about the option to deactivate the Menu activation altogether?  Does anyone actually use it in Photoshop?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

"How about the option to deactivate the Menu activation altogether?  Does anyone actually use it in Photoshop?"

I do, and very heavily. As I said before, it's standard Windows user experience and can be very powerful.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

The issue is the Alt key activating the Menu in Photoshop.  This often interferes with regularly used Photoshop shortcuts.  To reproduce easily and as an example, open Photoshop in Window's and press the Alt key once.  You'll see the menu items up top activate (shown by underline).  Press the space bar and you'll get the beeping.  This also interferes with many other shortcuts in Photoshop.

Pressing Alt is a Windows thing and I haven't yet found a way to turn this functionality off.

Edit: I should note that I was a Mac OS user for 15+ yrs and switched to Windows just over a year ago.  That might explain why I haven't used the Menu shortcuts in Windows.

Votes

Translate

Translate

Report

Report
Explorer ,
May 25, 2016 May 25, 2016

Copy link to clipboard

Copied

@Michael Orts
@Jeffrey Tranberry

RackMultipart20160525105154uh9-35ed69ee-f2b8-4228-8e42-0de278de05ad-1397855084.pngRackMultipart201605251154011i2-fe595abc-6536-41e9-904a-5b10d83d614f-1034463121.png
Here is how to reproduce the issue in a Windows Environment: 
1. Press the [Alt] key
2. Press [A] (or [U] to switch to the Path/Direct Selection or Shape tool.

What is happening is: when the user presses the [Alt] key and uses the scroll-wheel to zoom, the main window menus are highlighted.  ( As mentioned in a post earlier, this is a standard Windows Interface command that goes way back to version 3.11.)  See the attached images of the menu before and after the [Alt] key is pressed.  When the menus are highlighted by using the [Alt] key, subsequent presses of letters associated with a menu command become selected.  If there is no associated letter--such as with "A" or "U"--a 'beep' occurs.

  You may try this example that many people use: "[Alt], [F], [O] ", which will highlight the menus, select the File menu, then bring up the Open dialog--respectively.

This should provide Adobe with a solid reproducible base to start with.  Hopefully this will be fixed in the next release or patch.  I am sure there are plenty of creative coding work-arounds. 

Best Regards,

Christopher
UX & Product Designer

Votes

Translate

Translate

Report

Report