Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Magic mouse scrolling continues long after I stop scrolling

1 Vote
Enthusiast ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

I have had this problem for the last few iterations of Photoshop, but I can't remember when it started. I am surprised that I haven't seen anyone else mention it.

When I move the screen (for instance, when at 100% on a large document) using flicks on my Magic Mouse (Mac OS, of course), the screen will continue scrolling for 10-15 or more seconds after my last flick. This means that it is basically impossible to scroll using flicks on the mouse. I find using the space bar + drag much less intuitive and much slower, and since I can barely see the scroll bars in the modern Mac user interface, I am spending way too much time doing things that used to be dead simple.

Is there anything I can do about this?

(MacOS Mojave 10.14.2, Photoshop 20.0.2, Magic Mouse 2)

Bug Fixed
TOPICS
macOS

Views

340

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Oct 28, 2021 Oct 28, 2021
Working in current releases. Make sure GPU is enabled, and check your flick panning settings.
Status Fixed

Votes

Translate

Translate
New Here , Oct 18, 2021 Oct 18, 2021
If this is still an issue for others, the fix is in the "tools" preference overscrolling.  Uncheck this box and it's fixed.

Votes

Translate

Translate
8 Comments
LEGEND ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

Do you have Flick Panning enabled in Tools Preferences? I think it is by default. Maybe if you turned that off (if it's on), flicking with the magic mouse won't give you so much grief.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

Thanks Cristen. I did have it on, now have it off. This may have made a small improvement.

I'm not exactly sure how to describe this, but when I scroll in web browser or a pdf reader, a flick moves about 1/2 screen (depending on the size of the flick), and the screen slows down and stops after about 1/2-1 second. Doing two or three flicks is very much like single flicks in succession, but it doesn't slow down between them

When I scroll in Photoshop, unless I use very small flicks, the scrolling starts, then about 1-2 seconds starts making big leaps, then slows down and finally comes to a halt after 4 or 5 seconds.

And if I flick two or three times in succession, in Photoshop, all hell breaks loose, and the scrolling just continues for literally up to 15 seconds, and the scrolling is unpredictable, small scrolls followed by large scrolls, followed by small scrolls. And once the scrolls start, there is nothing I can do to stop them when the item I am looking for flashes by on the screen.

Part of the problem is that flick of about 1" on the mouse scrolls by about 1/2 screen in most programs, but scrolls by 2 or more screens in Photoshop. It really seems like Photoshop has had too much to drink!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

> It really seems like Photoshop has had too much to drink!>

LOL. I know it's not funny to live with, but it sure is funny the way you describe it.  It sounds to me like PS doesn't really support the Magic Mouse (mine died ages ago and I use a stylus anyway, so no flick scrolling. But I do have an old Logitech with a working scroll wheel so I just connected it. Flick panning is very controllable. In fact, it's only about a quarter of the screen flicking it as hard as I can.  I turned enable Flick Panning back on, and got a bit more distance out of it, but not much.

So I don't think the preference is doing much for either mouse. But Logitech sure isn't panning too far. Closer to the opposite—not really far enough, and it's one speed and an abrupt halt. No drifting at all.  The touchpad on my laptop is, in fact, very touchy. I easily pan too far with it, so only the slightest movement is good, and too much makes the pan stutter a bit. Or is that shudder? It's not perfectly smooth, iow. So what does Adobe have to do to adjust to all our mice? Or fingers, for that matter.<G>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

Our touch interface engineer will take a look. Thanks!

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Hi Alan.  Have you tried with the latest release (21.2)?  I can't reproduce the problem you're describing. If you are still experiencing this issue, can you attach a gif or recording of it? Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I'm having a similar problem but on the Touchpad via Macbook Pro Retina. What resolved it for me was turning the Graphics Processor back on. I turned it off because of a different issue (go figure) and then turning it back on (and restarting Photoshop) fixed it for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

If this is still an issue for others, the fix is in the "tools" preference overscrolling.  Uncheck this box and it's fixed.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

LATEST

Working in current releases. Make sure GPU is enabled, and check your flick panning settings.


Senior Product Manager - Customer Advocacy - Digital Imaging
Bug Fixed

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines