Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


20.2 June release - object ghosting (major screen redraw issues)

New Here ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

Not sure who beta tested this version or if Adobe's QA went on vacation during the pandemic, but this release is one of the worst we have seen!

 

Aside from the slower performance, there is a major flaw in screen redraw.  And yes, I posted a bug report this morning...just curious how many others are seeing this issue.

 

Everyone in our staff updated last week and can reproduce this problem on various machines (laptops, desktops) under Windows 10 using different nVidia video cards and drivers. We even updated to the latest nVidia driver this morning (released today on June 24) and it still happens.

 

Basically moving any object pasted from Illustrator (bitmap or smart object) leaves an imprint of the image (screen redraw issue) on the background layer and/or will cause other artifacting on the artboard and over various UI panels. Zooming in and out to refresh the screen does not fix this. Toggling the layers off and on will show what is happening (see the video).

 

I posted a bug report on this so hopefully Adobe tech support can respond with either a workaround or release a patch soon! It is driving our graphic artists crazy. It did NOT happen last week with the previous version.

 

Posting a screen recording and some screenshots.

 

We are running Windows 10 64-bit with various nVidia cards. Toggling the "Use Graphics Processor" on or off does not make any difference other than the full object shows with it on, and random lines and artifacts show with it off.

ANYONE ELSE HAVING THIS ISSUE?

TOPICS
Bug, Problem or error, Windows

Views

483

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Deleted User
Jun 24, 2020 Jun 24, 2020
Hi Go into preferences and disable legacy compositing if it's enabled and restart Photoshop, this update is one big mess, there's also this issue among others. https://feedback.photoshop.com/photoshop_family/topics/bug-in-photoshop-version-21-2-not-detecting-older-gpus

Likes

Translate

Translate
Guest
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

Hi

Go into preferences and disable legacy compositing if it's enabled and restart Photoshop, this update is one big mess, there's also this issue among others.

https://feedback.photoshop.com/photoshop_family/topics/bug-in-photoshop-version-21-2-not-detecting-o...

2020-06-24 17_44_08-Adobe Photoshop 2020.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

This fix worked for me  - I just updated to 21.2 and ran into the same issue 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

I believe you meant to write 21.2 not 20.2.  There Are problems in 21.2 one is that ghosting you can bypass the problem by not using the legacy compositing.  Adobe may fix the issue some day.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

to answer the other question, you beta tested it for Adobe so thanks for taking time to do that for them

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2020 Aug 10, 2020

Copy link to clipboard

Copied

THANK YOU! 

 

I was having this issue since the update on an iMac Pro and it was TERRIBLE having to toggle on/off layers to fix this issue. Disabling legacy compositing fixed it! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

This just started up on the 22.5 version of photoshop for me. 

Legacy Compositing has been disabled for this version of Photoshop from Adobe. 

Anyone else having this problem now?  Any suggested fixes? 

 

thank you! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

LATEST

Hi, Kimberly, that option has been retired, as most of the bugs have been ironed out.

Now the work on the underlying compositing continues, and the fallback mechanism to the older method can be found if you enable "Deactivate Native Canvas" in Preferences/Technology Preview.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines