Auto-blend error???

New Here ,
Oct 17, 2015 Oct 17, 2015

Copy link to clipboard

Copied

Whenever I try to auto-blend layers I get an error message saying, 'The parameters for command "Trim" are not currently valid.' How do I fix this?

Views

20.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2015 Oct 23, 2015

Copy link to clipboard

Copied

If you move your left most image down so that there is empty space top left with no pixels and then do the auto-blend you may find it is OK.

The Trim command tries to do a fill of empty pixels.

In history I find I have a number of steps when it completes normally

  Auto-Blend Layers

  Stamp Layers

  Trim

  Load Selection Fill

Photoshop is probably complaining that the Trim step has nothing to trim.

I think it is a bug but the auto-blend has worked (at least mine has) so don't worry about it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2016 Mar 03, 2016

Copy link to clipboard

Copied

I don't really understand your solution to the problem... I have the same problem and I really need to fix it...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 03, 2016 Mar 03, 2016

Copy link to clipboard

Copied

Are you using PS 2015.1.2 as seen in Help / About Photoshop CC or an older version?

Is the blend step failing or is it ok and you just don't like the message--the scenario Tony is suggesting?

If you have the latest PS and the blend step is failing would it be possible to post the image(s)?  Upload to www.dropbox.com and post a public share link, here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 03, 2016 Mar 03, 2016

Copy link to clipboard

Copied

Uncheck Content Aware Fill transparent Areas and see if that stops the error message.

ab.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2016 Mar 04, 2016

Copy link to clipboard

Copied

My solution to the problem was to ignore it.

The command has worked despite the error message

When you use Auto blend it has a number of actions which can be seen in the history panel (which I listed)

I believe the error is caused by the Trim step.

This is trying to fill blank space which it can't do if you have none.

I merely suggested created blank space so that you would see that the command didn't bring up an error message. It wasn't intended as a solution merely a demonstration of the issue.

As R_Kelly has suggested you could remove the fill option, but this is unnecessary (for my example) as the command has worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Have you found solution? i'm using latest PP (23.2.2) and still get same message.

1.jpg

Select booth layer1 and background copy , then edit -> auto bend. Then error happend

2.jpg

Please help, thanks

==============
Okie Eko Wardoyo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2022 Apr 16, 2022

Copy link to clipboard

Copied

LATEST

You should do a copy from the background and select layer 1 and go to modify>contract and give a number for example 10.
delete the layer 1 area from the copy of the background layer and do the blend with the copy of the background and layer 1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines