• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Black screen when editing text

New Here ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

I am running Photoshop 2022 on an M1 Max Macbook Pro (16", 2021). Photoshop is up to date as of 8/30/2022.

 

Whenever I go to type/change the text in a text box, the entire work area goes blank (everything inside and outside of canvas except for menus). I am able to enter and change the text successfully, but of course I can't see what I'm doing. It does not happen when I just select the text layer and change font, text size, edit layer styles, etc. This has only been an issue over the last week or few weeks at most - I think there was an auto-update in that time, but I'm not positive.

 

I have tried the Preferences > Performance > Graphics Processor Settings > uncheck Use Graphics Processor to no vail, and honestly, I don't think this would be a good long-term solution even if it did work given the processing capability of the M1 SoC that this would seemingly forego.

 

I'd appreciate any input on other workarounds. Otherwise, it seems like this is a bug that needs to be patched in a future update.

 

Thanks!

TOPICS
macOS

Views

701

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 31, 2022 Aug 31, 2022

Hi @defaultikvdcnsj3wj4 sorry to hear this.

 

Go to Preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur? 

 

If not, iet's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder ba

...

Likes

Translate

Translate
Adobe Employee ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

Hi @defaultikvdcnsj3wj4 sorry to hear this.

 

Go to Preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur? 

 

If not, iet's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Thank you,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2022 Oct 06, 2022

Copy link to clipboard

Copied

LATEST

Thanks, work for me! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

I had the exact same problem. I changed some options on preferences few weeks back and it started happening. 
so what i did to fix is ..
go to Preferences>Technology Previews

and UNCHECK both "Disable Native Canvas" and "Enable Native Canvas Rulers".

 

Let me know if it works for you! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

This worked, thanks! For me the setting was marked as PreferencesTechnology Previews Deactivate Native Canvas

 

So, similar but not exactly the same in case anyone else is confused by that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

Glad it helped 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines