• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Brush offset from cursor from using two screens

Community Beginner ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

Hello,

I recently did a hard reset on my Windows 10 laptop computer, and upon reinstalling Photoshop 2018 found a lot of problems arising. The Photoshop workspace is all pushed together and the brushes don't follow the cursor on my laptop screen. When I try to use a brush, it shoots away from my cursor in a diagonal line and doesn't follow. I have also found that the cursor flickers between the typical pointed arrow and a pointed arrow with eggtimer when sitting still.

I typically work with my laptop plugged into an external monitor, the laptop screen for Photoshop and the external window for references or anything else. This has never caused problems for Photoshop before, but I think is the cause of this, as when I move the Photoshop window onto the other monitor, the display for it is more suitable and the brush lines follow the cursor, and the cursor stops flickering an eggtimer.

Out of personal preference, and the fact that I am on a laptop, I need to find a way to fix it so that I can use Photoshop on my laptop screen properly.

Thank you,

Haydn

Views

4.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Mar 02, 2018 Mar 02, 2018

I have found a way to fix this, but it isn't a complete fix. In my Display settings on my Windows, changing the scaling of the smaller screen to 100% has resized the Photoshop window and made it more manageable, as well as fixed the brush offset. However, this in turn affects the whole laptop screen. Is there any way to limit this change to just Photoshop and not the whole computer?

Likes

Translate

Translate
Community Beginner , Mar 04, 2018 Mar 04, 2018

I found a fix, a rather half-done fix as the interface is still oversized for my laptop screen. I went into Photoshop 2018's properties and unchecked the box labelled 'Override high DPI scaling behavior box', which seems to have fixed all cursor issues I was having.

Likes

Translate

Translate
LEGEND ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

Are you using a mouse, touchpad, tablet if so what kind.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

I have a Wacom Intuous Pen and Touch tablet, and a Microsoft Mobile Mouse 1000. This happens with the mouse alone, and I've also sound that the mouse is almost delayed as it rolls over the drop down menus at the top of Photoshop. You have to roll as far over to the 'Help' drop down to open the 'View' drop down. I'm still unsure about what is causing the flashing eggtimer though.

I think it's down in part to the way the two monitors are aligned in Windows. I made a quick diagram of how they were set up originally vs. how they are now:

dual.png

which has resulted in a rather cramped workspace in Photoshop as if it is trying to upscale to the size of the larger screen on the smaller screen

example workspace.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

If you are trying to uses Photoshop where you have extended Photoshop's window across both displays I would highly recommend yot not do that.  The two displays  you have likely do not the same resolution and number of pixels. Things will display a different size on each display.  Photoshop can use all you displays.  Edit Your images on one display and put other Photoshop items one you other display like Photoshop Palettes you user often.  Here I have three Displays.  Two 1600x1200 100DPI displays on the left and right side of my 4K 3840x2160 185dpi display. On the left display I have Photoshop Window and all Photoshop's Palettes. On the center 4k Display I edit my Photoshop images in floating windows and On the right display  I Have Adobe Bridge open. Keep the image you are working on in a single display. Do not span displays.DellT3620Displays.jpgDellT3620.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

I'm not trying to span displays, but I think something in the computer is thinking that I'm wanting to. For whatever reason, and this is only on Photoshop (Premiere Pro and the like seem to be perfectly fine), the scaling of the windows on my smaller laptop screen seems to be that of the bigger external monitor.

What I want is for Photoshop to remain on my smaller laptop screen, but formatted to fit the smaller laptop screen. But each time I open it, the whole interface is scaled as if it WAS on the bigger screen. The fact the brushes' lines move a distance away from the cursor seems to suggest the program is formatted to work on the bigger screen rather than the smaller screen I want it on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

I have found a way to fix this, but it isn't a complete fix. In my Display settings on my Windows, changing the scaling of the smaller screen to 100% has resized the Photoshop window and made it more manageable, as well as fixed the brush offset. However, this in turn affects the whole laptop screen. Is there any way to limit this change to just Photoshop and not the whole computer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

I found a fix, a rather half-done fix as the interface is still oversized for my laptop screen. I went into Photoshop 2018's properties and unchecked the box labelled 'Override high DPI scaling behavior box', which seems to have fixed all cursor issues I was having.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

LATEST

This fixed my issue, thank god I found this !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2018 Dec 05, 2018

Copy link to clipboard

Copied

I have dual screen and one of them is a Huion Kamvas display. Both screen have same resolution of 1920x1080 but I also had the problem of brush cursor offsetting. I found the issue was that the two screen was offset a little bit. Here's where I went and align them

NVIDIA Control Panel (whaterver graphic card you're using) -> Set up multiple display -> when you click on one of the screen it actually tells you how many pixel that screen is off. I just adjusted it until it said 0 (perfectly alligned) then it worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines