Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Can't control lighting effects in PS CC

Participant ,
Jul 21, 2013 Jul 21, 2013

Copy link to clipboard

Copied

I am running both PS CC and CS6 on my mac mini  (late 2012, 2.3 i7, 16 GB ram). When I try to use the lighting effects filter on CC, it opens, and all the sliders in the properties box work, but without the tools to point and modify the light source. On CS6, lighting effects opens with the expected oval shaped tools and the intensity adjuster. I am assuming that it is not the Mac-mini, as it handles both versions, CC and CS6, without issues except for this. Is this a bug in CC? I have searched and found nothing to this effect. I am assuming the video capabilities are adequate as the lighting effects option is not greyed out in either version. Also, I have made sure the image I am working on is in 8 bit mode.

Views

22.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Dec 14, 2013 Dec 14, 2013
To use on-image lighting controls:View>Show> All

Likes

Translate

Translate
New Here ,
Aug 25, 2015 Aug 25, 2015

Copy link to clipboard

Copied

I am having the same problem. Handles are available but can not be adjusted. Parallel directional and soft direct work but no other lighting effects. Windows 10, i5 processor at 3.3GHz, 16 gigs ram, nvidia GeForce GTX 570. All drivers up to date.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

this doesn't work for me is there anything else i can check?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Same problem for me. View > Show > All doesn't work. I have no lighting controls to work with, I'm using Windows 10. If I click on the workspace then the controls appear but when you unclick they disappear so you can't grab the handles.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Did any of you upgrade to 2017.1 as of late and attempt again to run lighting effects ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2017 Jan 05, 2017

Copy link to clipboard

Copied

Try

Mac CMD+H

Win.  Ctrl+H

It worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 05, 2017 Jan 05, 2017

Copy link to clipboard

Copied

This doesn't work for me unfortunately

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 17, 2017 Mar 17, 2017

Copy link to clipboard

Copied

Where's my update?  Come on Adobe, fix this. I've paid you in good faith over $240 now, and still, no update to fix this problem!

ENOUGH!  I'll getting on the phone and in your face soon. I give you two more months to release an update to your initially trashed software. FIX IT.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2017 Mar 17, 2017

Copy link to clipboard

Copied

I had the exact same problem recently. After trying numerous things, I reset my preferences and it resolved the problem. I have no idea why that worked, but it did.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

Some have suggested View>Show>All ...but that turns on everything (grid, guides, slice outlines, etc) - However just turn on View>Extras (or ⌘H) to just get the lighting controls.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 10, 2018 Mar 10, 2018

Copy link to clipboard

Copied

2018 and this is still an issue... Amazing how little adobe cares about their user, aside from when billing them...

After a clean install of Photoshop on High Sierra the on screen lighting controls are NO WHERE to be found by default. They are only THE MOST important controls of that filter, so why NOT turn on the controls by default ?????

Once STILL cannot turn on ONLY the Lighting Controls - One has to select view->All and then one by one turn off the ones he does not wish to see....

This carelessness is the result of subscription services.

"Hey, why should we fix bugs when you are dumb enough to pay us every months regardless...."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Not solved at all.

I'm using a MAC with the latest OS and the latest version of PS in CC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Hi

 

I'm using the latest version of CC. My drivers are all up-to-date. I have played around with preferences, I have done the 'view>show all' method but nothing. I cannot get the lighting effect controls. This is all I have. I have the sliders on the right (which don't seem to do anything). I'm running a pretty powerful machine because I play online games too.

 

default4bmivlnf1jd0_0-1626709856388.png

 

Would really like a solution OR an alternative (I'm a novice in PS so any advice is welcome).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Found the solution in 3 different posts:

  1. https://community.adobe.com/t5/photoshop-ecosystem/lighting-effects-has-suddenly-stopped-working/td-...
  2. https://community.adobe.com/t5/photoshop/filter-rendering-lightning-effects/td-p/12060568
  3. https://community.adobe.com/t5/photoshop/lighting-effects-not-working/m-p/12058303#M544671

To summarize:

"Some functionality in Photoshop, such as 3D and Lighting Effects, still relies on the older Open GL graphics functions. To make these work, an additional preference Preferences>Technology previews>Deactivate Native Canvas has been added. This can be checked and Photoshop restarted to restore 3D functions to where they were in 22.3"

2021-05-20 09_59_13-Window.png

Cridet goes to the links above!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

LATEST

O my sweet Lord Jesus It works, it really Works!!!! You did it! Tank you Sr. Tank you, Tank you , Tank you , Tank you!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2