• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Can't save a text file as a .tga targa file

New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

I've created a simple text layer and wish to create an alpha layer transparency for its background. PS prompts me first to rasterize the text and save.  I then load the layer and save it. When I go to save, however, the rasterized text remains selected (showing those lines one sees when selecting with the magic wand).  This isn't working as the files I save don't create a transparency alpha channel background.  Can anyone help?  Thanks in advance

TOPICS
Actions and scripting

Views

136

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jul 18, 2022 Jul 18, 2022

Cmd or Ctrl click on the Text layer thumbnail in the layers panel to load a selection of the text, then go the channels panel and click on the Save Selection as Channel icon, which adds an alpha channel and then Select>Deselect.

 

Then when you save as tga file, check 32 bits/pixel to include the Alpha channel.

Likes

Translate

Translate
Community Expert , Jul 18, 2022 Jul 18, 2022

The red color in the layers panel is because the alpha channel is active. If you click on RGB in the channels panel the red should disappear.

 

Maybe when you go to Save a Copy your not seeing the whole list of fiile formats because the bottom of the list needs to be scrolled up by moving the mouse down at the bottom of the list.

Likes

Translate

Translate
Community Expert ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Cmd or Ctrl click on the Text layer thumbnail in the layers panel to load a selection of the text, then go the channels panel and click on the Save Selection as Channel icon, which adds an alpha channel and then Select>Deselect.

 

Then when you save as tga file, check 32 bits/pixel to include the Alpha channel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Thanks, will try, but just wanted to clarify - I contol click on the text layer thumbnail to load the selection after or before rasterizing the text?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Hi there - so I followed your instruction hitting ctrl click of the text layer thumbnail in two cases: before rasterizing the text and after. In both cases when when I go to the channels panel to save selection as a Channel icon, that icon at the bottom is grayed out and won't let me select.  Did I misapply your instruction?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

After you Ctrl click on the text layer thumbnail in the layers panel you can see an active selection (marching ants) around the text?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Ah, I finally followed and it worked to save the alpha channel. The marching ants inside the text disappeared and the text turned a solid white (its color was created in orange).  I checked the text layer and it has a semi transparent red band through it.  Please see attached.

However, when I go to save as or save as a copy, neither shows a drop down option to save as a targa, .tga file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

The red color in the layers panel is because the alpha channel is active. If you click on RGB in the channels panel the red should disappear.

 

Maybe when you go to Save a Copy your not seeing the whole list of fiile formats because the bottom of the list needs to be scrolled up by moving the mouse down at the bottom of the list.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

I've followed your steps and appear to have gotten the alpha file saved, but still unable to save as a targa file.

I was able to eliminate the red block out feature on the text layer by clicking on the black background layer that I had and unlocking.  I then deleted the black background layer.  The text layer now appears to have a transparency background (with a semi-transparent red layer over it).  I then turned to try to both 'save as' and 'save a copy'.  Neither worked. I definitely scrolled all the way down the list of options trying to save and the targa option is missing. Attached are screen shots to show the menu drop down list in 'saving a copy' as well as save a copy along with the channels and layers views. I included the save as option screenshot without drop down list to show that the alpha and layer channels are checked, along with sRGB.  Please suggest what I might be doing wrong?  Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

LATEST

Got it to finally work.  I had taken the magic wand to get rid of the crawling ants feature after the Alpha channel was created.  I duplicated your steps again without getting rid of it and the targa file save as option appeared.  Thanks for your help!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines