Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Canvas Size for converted smart objects

Community Beginner ,
May 27, 2019 May 27, 2019

Copy link to clipboard

Copied

When I convert layers to a smart object, the default canvas it's on is the size of the original canvas rather than the size of the object--I alawys have to go into the smart object file and crop it--is there anyway to change this default?

Views

317

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2019 May 27, 2019

Copy link to clipboard

Copied

Can you post screenshot please? The default behavior when converting to Smart Object is to encapsulate object but not to change canvas to match object dimensions and there isn't anything in preferences to change that behavior.

By the way after converting object to Smart Object layer you may be confused by what you see as thumbnail in the Layers panel. To see only layer bounds click on Layers panel menu > Panel Options then change in the Thumbnail Contents to Layer Bounds.

layer panel options.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 28, 2019 May 28, 2019

Copy link to clipboard

Copied

I think it's impossible. You create Smart Object to protect all data on your layers. It allows you to find different crop area later.

I you want to crop smart object just Select All (CTRL+A) and use CTRL+J command to prepare a new cropped Layer before nonverting to Smart object. This way convert toSmart object a new created, cropped layer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

I found that there must be some layers, or layer effects that has a "Layer Mask". You should get rid of it first.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

LATEST

yes this problem occurs every time there is some content in the file that is larger than the crop area, such as layer mask. The easiest to do is simply to convert the smart object into a smart object. This way it clips perfectly to visible content. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines