• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Could not fill because the current canvas size does not match

Engaged ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

I noticed lately for the past month or so that whenever I use Alt+Backpasce (foreground fill) to fill a layer with the foreground color, Photoshop gives me the error, "Could not fill because the current canvas size does not match".  When looking online for a solution I saw a post on reddit, that says that it has something to do with resizing the canvas between the current state and the history state selected for the history brush. 

I am not using the history brush, all I am doing is using Alt+Backspace to fill a color on the canvas. I've never had this problem until recently in 2021 and I've ben using Photohops since 2007. What is happening? I found another post that is similar on graphic design stack exchange, but there were no replies. 
This error happens randomly so I can't pin point any specific cause. If I make a new file, it works fine, then I go back to the old and sometimes it is fixed, other times it isnt. 

Also if I manually make a selection and right-click and select fill, and foreground it works fine. 
EDIT: This is ONLY a problem with FOREGROUND, the background shortcut CTRL + Backspace works fine. 

 
Specs:
OS: Windows 10 Build 19042
CPU: Intel Core i7‐4770K 3.5GHz Quad‐Core​
RAM: 32 GB
GPU: Asus GeForce GTX 780

TOPICS
Windows

Views

4.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Expert ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied


@campbellma wrote:

...resizing the canvas between the current state and the history state selected for the history brush. ...I am not using the history brush,

 

By default, your History panel is recording 50 steps. That number can be changed in Preferences. The column of squares to the left of the panel is for choosing a state for the History Brush. By default, the State is on "Open", and that can also be changed. See how it works here:

https://helpx.adobe.com/photoshop/using/tool-techniques/history-brush-tool.html

 

If you resize your canvas, you might take a Snapshot (camera icon) and use that for the History State. Don't revert back to it. Just set it as the History State by clicking in the small square on the left.

 

Play with this on a simple document to learn how it works.

 

~ Jane

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Wierd. I dont ever use the history brush or panel, and Ive never had this issue before. thanks I will look into this. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

I'm still having this problem, so far clearing history doesnt really change anything. 
I added and extra peice of info to the origianl post.
"This is ONLY a problem with FOREGROUND, the background shortcut CTRL + Backspace works fine." 
Why would history be the issue if it is only effecting Foreground fill but not background, arent they basically the same function with differnt inputs?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 04, 2024 Jul 04, 2024

Copy link to clipboard

Copied

I am having excatly the same problem. I await the response!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 04, 2024 Jul 04, 2024

Copy link to clipboard

Copied

LATEST

Please read this (in particular the section titled "Supply pertinent information for more timely and effective answers”):
https://community.adobe.com/t5/using-the-community/community-how-to-guide-tips-amp-best-practices/td...

 

Could you please post screenshots with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible to illustrate the complete process? 

 

What have you done for all-purpose trouble-shooting so far?
Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:
https://helpx.adobe.com/photoshop/using/preferences.html
https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html
https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines