Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


decontaminate colors

New Here ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

For PS CC2017, the output "decontaminate colors" box remains gray and will NOT let me selct it. I cannot find an answer to this problem after 2 days of searching online including tutorials, so this appears to be not a common problem but it is my problem. Can anyone give me an answer??? please??

Views

7.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 15, 2017 Jun 15, 2017
If you are on a pixel layer and not on a shape layer as pointed out by Barbara in post 3, if you still can't get the option try resetting Select & Mask. With Select and Mask open go to the top right and click the down arrow then choose Reset Select & Mask.Hopefully that will allow you to choose the option.However - Decontaminate colors is not good, it is destructive, and rarely works well.A better, non destructive,  and much more controllable method is :Add an empty layer above your masked layer...

Likes

Translate

Translate
Adobe Community Professional ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

Can you post a screenshot?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

If an adjustment layer or a shape layer is active, decontaminate colors will be grayed out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

Please post a screenshot and version of PS cc 2017  i.e. 2017.1.1 is my current version of photoshop CC 2017.

You can also try to open the select and mask as a popup which might help -

Go to the Select and Mask option in the menu bar. Hold down the shift key and click on Select and Mask. The Refine Edge/Mask panel will pop up instead of the opening the Select and Mask workspace. Trying using decontaminate colors with slider.

Vishu Aggarwal
Adobe Certified Instructor, Professional and Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 15, 2017 Jun 15, 2017

Copy link to clipboard

Copied

If you are on a pixel layer and not on a shape layer as pointed out by Barbara in post 3, if you still can't get the option try resetting Select & Mask. With Select and Mask open go to the top right and click the down arrow then choose Reset Select & Mask.

Hopefully that will allow you to choose the option.

However - Decontaminate colors is not good, it is destructive, and rarely works well.

A better, non destructive,  and much more controllable method is :

Add an empty layer above your masked layer and Alt click on the border, in the layers panel, to clip this new layer to the masked layer.

Set the new layer blending mode to color

Now get a soft brush and using color from the image (Alt click to pick up color) brush round the contaminated edges. The clipping mask will ensure it only paints on the edge of the image and does not overflow

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

Well, having read all of the replies, even the "correct" one (not sure who decided that), I still had the problem as described by the original post. So, rather than try to tell you what not to do, like some of these people, I'll tell you how to get the stupid grayed out "Decontaminate Colors" box to come alive:

While inside of the "select and mask" option, take a look at the upper left side of your screen. You should see a box called "Sample All Layers".  Make sure that it is unchecked!  That's all it takes...magic.

And by the way, it worked for me, destructive or not...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

I tried that but I still have the decontaminate color greyed out.  I usually choose this option in order to save all the work I just did cutting out an object (that is how I was taught).  Is there another way to save onto a clear background that I'm missing. I have tried everything and I am really frustrated and don't want to close out my work.Photoshop problem.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

very helpful and didnt over complicate things, thankyou.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

you are the best! so simple 🙂  thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

LATEST

Thank you so much! That's "the correct" answer!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines