• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

Full screen mode

Explorer ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

When I click on the green dot in the image window in Photoshop, the image was previously scaled to the window size. For a few days now, clicking on it has shown me the image in full screen mode.

 

What do I have to change so that it returns to the way it was, i.e. when I click on the green dot, the image is set to window size and not full screen?

Activate native full screen in the preferences is not activated. When I activate it nothing changes.

Photoshop Version 25.4.0

TOPICS
macOS

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Expert ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

What version of macOS are you using?

 

What happens if you Option click on the Green Maximize button?

 

Perhaps resetting the Photoshop preferences will fix the issue:

https://helpx.adobe.com/photoshop/using/preferences.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

I'm using Sonoma 14.2.

OPTION an Green does work and fits the picture to the frame.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

One thing i forgot to mention is when you change Activate native full screen in the preferences, photoshop needs to restarted for the change to take effect.

 

So try going to Photoshop>Settings>Workspace check Enable Native Full Screen, then restart Photoshop.

Now go to Photoshop>Settings>Workspace and uncheck Enable Native Full Screen, restart Photoshop and see if that made any difference.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
People's Champ ,
Feb 04, 2024 Feb 04, 2024

Copy link to clipboard

Copied

The solution you suggested does not resolve the issue. In version 25.4, the full screen on/off setting in preferences only functions in Photoshop's Application Frame mode. When Photoshop is in window mode, even if the native full screen is turned off in preferences, the window's behavior defaults to native full screen.

The checkbox for native full screen in Photoshop preferences only applies to the Application Frame. The behavior of the "green button" for each window becomes native full screen, regardless of whether native full screen is turned off or not. This behavior differs from previous versions. It seems like a check for each window's behavior was overlooked.

Please verify this in development.

--
Yamonov

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

This is how I work, without the application frame, and it is definetely a bug as it leaves my document permanently stuck in full screen mode no matter how many times I press F, Tab, or change the View settings. It didn't start happening until version 25.4.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

I'm also having the same problem and it's so frustrating. F, tab, esc, fn + f11 do not work. The only workaround I have is to quit and restart PhotoShop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

I should add that there are other effects from this. Tested on 25.4 and 25.5, does not happen on prior versions. While Photoshop is stuck in this mode my second screen is blacked out except for the Photoshop palettes. While quitting Photoshop in this stuck mode the whole screen flashes solid red for a split second. I have InDesign and Illustrator open at the same time, and sometimes their window pallets are all repositioned when returning to them after quitting Photoshop, but opening a document in them returns the pallets to where they are supposed to be. Needless to say I’ve gone back to 25.3 for some sanity.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 05, 2024 Feb 05, 2024

Copy link to clipboard

Copied

I have the same situation on macOS Ventura 13.6.4/Photoshop version 25.4.0. I think this one is a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2024 Mar 10, 2024

Copy link to clipboard

Copied

Same problem. Must be a bug. Frustrating!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2024 Mar 10, 2024

Copy link to clipboard

Copied

Try hitting F3 and then drag the desktop icon to the main screen.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2024 Mar 11, 2024

Copy link to clipboard

Copied

Option clicking on the green dot does toggle the fullsize option. This is very annoying and should not be "a thing".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2024 Mar 11, 2024

Copy link to clipboard

Copied

Someone mentioned the F3 key. This works, but with a few other steps. When stuck in full screen mode hit the F3 key, this will take you to the desktop with multiple window options, you'll see the PhotoShop document option, hover over the left hand top corner and a circular icon with two arrows appear (resize), click it and the window will open in the finder, now you can click on the document's tab and it will open the file in Photoshop out of the full screen mode. This "lenghty" process works as I've done it a few times now to confirm but it's a pain. Hopefully they Adobe will fix this issue and simplify it as it was.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2024 Mar 11, 2024

Copy link to clipboard

Copied

This is why Adobe waited so long to implement native full screen mode, because it was going to be a mess. Thank everyone who whined about it.

You'll have to experiment or use a script to set window size instead.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2024 Mar 15, 2024

Copy link to clipboard

Copied

Thank you so much for the option click tip! 

What I was doing after hitting the green button was pressing control and the arrow up key. That takes me into mission control and I can hover over the window on top of the screen that shows my workspace, then I click on the 2 arrow symbol that appears. It places the window from the topto the middle of the screen and I click on it. Then I'm back in photoshop with the window visible again. This is somewhat anoying as it breaks my momentum. I'll be option clicking from now on.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2024 Mar 19, 2024

Copy link to clipboard

Copied

Did you solve this? Its driving me crazy!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 19, 2024 Mar 19, 2024

Copy link to clipboard

Copied

Read my reply Mar 11, 2024. That definitely solved it for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 19, 2024 Mar 19, 2024

Copy link to clipboard

Copied

It looks to me like the behavior with Application Frame off is consistent with how macOS full screen works in every other standard Mac application. The reason it looks “wrong” to some is that up until now, Photoshop was not complying with macOS, and now that it is, it’s catching people off guard. I do think there is something Adobe could improve about this (many Mac apps have an Enter/Exit Full Screen command discoverable on the menu), but the overall behavior is now consistent with macOS.

 

The rules below are how it works for a floating document window in macOS in general, which now Photoshop is, after all these years, finally consistent with:

 

If you click the green button, the window goes full screen.

If you only want to maximize the window, option-click the green button.

 

But the Photoshop implementation is not complete. The lack of a macOS Enter/Exit Full Screen command makes it harder to get out of full screen mode. (Photoshop still has its Screen Mode commands on the View menu, but those are for the Photoshop traditional full screen mode, and are not connected to macOS or Windows full screen mode. Similarly, the green button function is macOS and not connected to the View > Screen Mode commands in Photoshop.)

quote

When Photoshop is in window mode, even if the native full screen is turned off in preferences, the window's behavior defaults to native full screen.

By @Yamonov

 

This is consistent with other Mac apps that have no other full screen mode. For consistency with macOS, the default for a window is native full screen mode. Yes, you can argue that it should follow the setting, but my point is that once you realize it’s following macOS rules, then it becomes clear how to use it.

quote

This is how I work, without the application frame, and it is definetely a bug as it leaves my document permanently stuck in full screen mode no matter how many times I press F, Tab, or change the View settings. It didn't start happening until version 25.4.

By @Larry29731486lwom

 

What is happening is that you are trying to use Photoshop shortcuts (F, Tab…) to control full screen mode when macOS full screen mode is in effect, and that is not going to work. The F/Shift+F shortcuts apply only to the View > Screen Mode commands, which are Photoshop/Illustrator only. The Tab key hides panels in Adobe apps, not macOS.

 

Yes, it is reasonable to submit a feature request to Adobe to make floating document windows follow the Photoshop full screen setting. But until they do that, the answer is, as long as you understand how macOS full screen mode works, use the same standard techniques you’d use in other Mac apps to manage whether a floating Photoshop document window is full screen or maximized.

 

If a window is using macOS full screen mode, then the macOS standard way to get out of it is to hold the pointer at the top edge of the screen to reveal the menu bar, and when that drops down, click the green button to exit full screen mode. The problem with this in Photoshop is that the top menu bar can be hidden if the panels are displayed. (This is a symptom of the two windowing systems clashing.) I found that if I simply hit Tab to hide the Photoshop panels, then the menu bar can be visible when it drops, the green button can be clicked, and the Photoshop window exits macOS full screen mode. Then I press Tab to get the panels back.

 

By the way, the same thing happened with Adobe Lightroom Classic. Like Photoshop and Illustrator, Lightroom Classic originally built its own full screen mode before macOS introduced its full screen mode. A few years ago Lightroom Classic also started supporting macOS full screen mode, but did not remove its own traditional full screen mode. Today, both full screen systems exist in that app too, leading to some confusion about how to get in and out of full screen mode. As in Photoshop, the answer in Lightroom Classic is to understand whether you’re using OS or application-specific full screen system, and stick to the commands and buttons for just one of them. Because mixing the two systems just doesn’t work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 19, 2024 Mar 19, 2024

Copy link to clipboard

Copied

This is a poster boy for just bolting on a feature. I suspect that its being done now because Adobe is already changing its graphics/windowing model.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

LATEST

This problem is very troubling.
Even if I adapt it to Mac Os, Illustrator will stay the same.

The green button in Illustrator should be matched to Illustrator as it was before. It is strange that only Photoshop changes.

It's a temporary solution, but double-clicking on the title-bar works as before.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines