How can i turn off "pressing ctrl or alt selects the menu at the top of the screen" in CS4?

New Here ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

I'm not marking this as a bug because I actually need help and I'm on an old version, but this is C L E A R L Y an extremely severe critical glitch. I need to do pixel-perfect moving like, literally all the time, it's basically half of the work with the projects I do. There's just one problem. If I press CTRL and press the DOWN arrow, the stupid app open menus at the top of the screen then only moves the layer one pixel down, and if I keep pressing the down arrow, it just cycles menu options. THIS IS OBVIOSULY NOT WHAT I'M TRYING TO DO, AND IS CLEARLY A GLITCH.

 

How do I turn that off?

TOPICS
Windows

Views

125

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

What version of windows are you using?

 

Are you moving paths, shapes or pixel layers?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

I'm not sure of the specific version number, but I'm on Win10 and it updated like 5 days ago for me. I'm trying to move actual content (what you would call "pixel layers")

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

On Windows it is function of Alt key to allow selection of menu items using letters on keyboard. When pressing Ctrl with some (any) tool active app should switch to Move tool temporary. If Move tool is active Ctrl should turn on/off Auto Select in the Options bar. That is behaviour for a long time backward including CS4 if I can remember correctly. Perhaps your keyboard is some other language then English or similar issue?

 

If you need to move some object precisely, why you are holding Ctrl key? To switch temporary to Move tool to be able to use nudging functionality or something else? If you activate Move tool only arrow keys should be enough to do what you want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

Why would I ever use the move tool if pressing CTRL while using a Selection tool does the same thing? Honestly I think Move just shouldn't exist because that'd be a huge workflow break to have to manually go over and click on something just to move a layer like two pixels down.

 

I'm using a standard US-EN QWERTY board. What  does any of this have to do with disabling a glitch to make moving more consistent?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

 


@Snöiller Fitzroy wrote:

How do I turn that off?


 

When you press and release the Alt key in Microsoft Windows, it activates the menus. It's not just Photoshop. When Windows first came out, PCs didn't come with a mouse and everything had to be done with a keyboard. I started using Windows with version 2.0.

 

 

The Control key does not activate the menus. As was said, it is a shortcut for the Move tool. You may be pressing the wrong key if you think Control is activating your menus — either that or something may be flaky with your keyboard?

 

Macs, btw, don't have the Alt (Option) keyboard shortcut to activate a menu because they have always had a graphical user interface (GUI) and have always come with a mouse.

 

I hope this helps,

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

Not sure why soemone gave this a like as it's completely unhelpful - I don't see why you're briging up Macs as no self-respecting computer user would ever consider anything that isn't Windows - I also don't recall asking for a history lesson on Windows versions. Even if it's actually the ALT key (in which case that'd be zooming in and out before moving something, which sounds closer to what's happening now that my memory is a bit more clear, but it still shouldn't open the menus, NO MATTER WHAT.) If I wanted to open the menus, I'd click them. I should not have to be constantly reminding myself "Okay, I pressed ALT then scrolled, gotta press escape now" when ALT+scroll and CTRL+arrows are muscle memory (that is, I have the thought of "I would like to zoom in/out" and it just sort of happens), the app shouldn't be behaving like this to begin with.

 

So again, I ask: How do I prevent menus from opening without explicitly clicking on them for the purpose of deliberately opening them?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied


@Snöiller Fitzroy wrote:

So again, I ask: How do I prevent menus from opening without explicitly clicking on them for the purpose of deliberately opening them?


 

 

Short answer:
You cannot disable the Alt key to activate the menu system in Windows OS using Photoshop.


The use of the Alt key to open menus is part of Windows OS, not part of Adobe. The reason I mentioned macOS is because the keyboard shortcuts have never been part of macOS and therefore do not exist when using Photoshop. One option for you if you hate the Alt shortcut to activate menus would be to switch to macOS.

 

While keyboard shortcuts were required when Windows was text only, they apparently no longer are. You can disable them as I said previously. The directions are in the links from Microsoft that I gave you in the first reply, plus you will find that there are dozens of other links if you do an internet search. Disclaimer: I have not done this. I use the shortcut when I am on Windows.

 

This is not a Photoshop question. It is a Microsoft question. If you have further questions about how to disable the Alt key to activate your Windows menu system, please ask on the Microsoft forums. Here is the link:

https://answers.microsoft.com/en-us/windows/forum

 

Good luck,

Jane

 


@Snöiller Fitzroy wrote:

Not sure why soemone gave this a like


 

Your guess is as good as mine. Could it be that someone found it helpful?

 

Cheers,

Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

LATEST

'Not sure why soemone gave this a like as it's completely unhelpful'

I did, because Jane both explained the Alt functionality of Windows and gave you a couple of links on how to disable it. 

 

'no self-respecting computer user would ever consider anything that isn't Windows - I also don't recall asking for a history lesson on Windows versions'

How rude. As a moderator, let me remind you of the forum guidelines - be respectful

 

'So again, I ask: How do I prevent menus from opening without explicitly clicking on them for the purpose of deliberately opening them?'

Read and follow Jane's links to the Windows forums on how to disable that Microsoft Windows function.

 

Dave

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

Yes windows users, specifically photoshop users, as it pertains to this forum, have been complaining about the Alt key issue for as long as i can remember, however, it seems adobe has actually done some work in photoshop to try to mitigate the "Alt" key problem in later versions of photoshop.

 

Anyway, that doesn't really help you if you don't plan to upgrade from cs4, but i can offer a suggestion of rather than using the Alt key when you zoom your photo, you go to Edit>Preferences>General and check Zoom with Scroll Wheel so you don't have to press the Alt key when using the mouse wheel to zoom.

 

 

Screenshot-(10).png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines