• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
5

How do I fix PS making one of my layers black and white when I export

Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

I was about to export this project assuming it would export the same way I edited it. But when I go into the export tab it shows one of the layers as black and white. I clicked Embed colour profile. I waited a few minutes in the window to see if it was fixed, but nothing happened. I exported it and checked the image; the layer was still black and white. 



Screenshot 2023-11-26 203938.png

Screenshot 2023-11-26 203852.png

 
TOPICS
Windows

Views

340

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 26, 2023 Nov 26, 2023

100% zoom is the accurate preview of your document blend. When zoomed out you are not seeing an accurate preview but a blend based on combined pixels in each layer. For 99% of images the difference is not noticeable, but when fine noise is involved the difference can be dramatic, as you have seen in your document.

 

So you need to remake your layer blending so it looks the way you want at 100% zoom. That will flatten and export OK.

 

Dave

Votes

Translate

Translate
Adobe
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

That's a pretty big file for web/screen/mobile, which is what Export is intended for. Are you sure you don't want Save As/Save A Copy instead?

 

But yes, there is clearly something wrong here. This is a layer compositing error, and layer compositing is (AFAIK) executed in the GPU nowadays. So that would make it a GPU driver bug. Try to update the driver, and use the Studio driver, not the Game Ready driver.

 

If you really do need Export and not Save, you can try Save For Web as an alternative (although I'm not sure it will handle the file size).

 

Is this a laptop with dual GPUs? That's a constant source of problems and you may need to disable the integrated GPU to avoid conflicts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

Im updating the driver right now. Ill let you know if that works. I have a PC with an RTX 3060 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

I updated it and still it happens

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

I even just tried exporting the file from a different computer (MacBook) and still it didn't work. I also disabled the GPU on my PC and it didn't work and updated it. I think it may be something in the project. 
I found that the black and white part is one specific layer which is "lotus copy" This is under a gradient map and that's what is supposed to give it colour in my project.

Sachin338638707w14_1-1701031108883.png

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

OK, maybe you need to clip the gradient map layer to the underlying pixel layer.

 

Still, it should export as you see it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

Can you show the problem section of the image at 100% zoom (Ctrl+1) before you export

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

at 100% it zooms in alot and losses colour also clipping them together didn't work

Sachin338638707w14_0-1701032164751.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

Ah, yes, of course. I should have seen that coming 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

What should I do then

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

100% zoom is the accurate preview of your document blend. When zoomed out you are not seeing an accurate preview but a blend based on combined pixels in each layer. For 99% of images the difference is not noticeable, but when fine noise is involved the difference can be dramatic, as you have seen in your document.

 

So you need to remake your layer blending so it looks the way you want at 100% zoom. That will flatten and export OK.

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2024 Mar 25, 2024

Copy link to clipboard

Copied

having a similar issue, it keeps doing this for me even after i remake the layer. Why does it do it, is there a reason? With the horrificly high prices of adobe this should not be an issue whatsoever. Is there a way of preventing this from happening in the future, is it a random bug? If it isn't do i now have to edit everything in 100% zoom?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 26, 2024 Mar 26, 2024

Copy link to clipboard

Copied

LATEST

It is not a bug, it is the way pixel preview is done for speed of performance.

At 100% zoom, which in Photoshop means 1 image pixel mapped onto 1 screen pixel,  each individual pixel is blended and displayed. When zoomed out those pixels are grouped together in each layer then blended. Imagine the performance if a 50 layer doc with 20000x20000 pixels, zoomed out to show the whole image, had every single pixel in the image recalculated individually every time it was altered slightly.

As said earlier, for 99% of images, this compromise, made to enhance speed of response, makes no visible difference. However, for those with very fine noise then it can alter the previewed blending result which is why it should be checked at 100% zoom where only the pixels on screen need to be fully recalculated.

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines