Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How to prevent panning during brush near edge?

Community Beginner ,
Aug 10, 2017 Aug 10, 2017

Copy link to clipboard

Copied

I'm drawing straight lines with the brush tool by holding down shift while brushing. This works great except when my brush gets near the edge of the screen photoshop pans the canvas, messing up my screen recording of the drawing. Here's an example:

photoshop-pan-brush.gif

Is there any way to either:

  • lock the canvas scroll position?
  • disable panning while brushing?
  • disable the canvas extension so there are no scrollbars at all?

This is driving me nuts, hope somebody knows a workaround!

Views

2.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 11, 2017 Aug 11, 2017
Hi TrevorI did a quick check on the feedback site and didn't turn anything up.Geddesign99  You can submit a feature request here :Photoshop Family Customer Community Dave

Likes

Translate

Translate
Adobe Community Professional ,
Aug 10, 2017 Aug 10, 2017

Copy link to clipboard

Copied

I can't make that happen on CC and Windows 10.

Does the cursor change to the Hand tool when this happens?

Are you using mouse or tablet, or does it happen with both?

Is the canvas larger than your screen?

Do you hold down the Shift key after you place the cursor, or before you start the stroke?

I am wondering if it is to do with a Preference setting.  I tried turning off Over scroll which made no difference.  I see you are using a Mac.  Does it have the Touch Bar?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 10, 2017 Aug 10, 2017

Copy link to clipboard

Copied

Cursor doesn't change. Happens with both mouse and tablet. The canvas is the same size as the screen, or slightly smaller. Happens regardless of click/shift or shift/click order. I just confirmed that it happens on my windows 10 machine as well. So long as you're holding shift with the Brush tool (or pencil) as soon as you get about 40 pixels from the edge, it pans the whole document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

It happens here if the document view is zoomed in. Brushing towards the edge of the window then scrolls. If zoomed out so that the document fits the window there is no auto scroll.

It is normally wanted as it means you can draw a line to another part of the canvas even while zoomed in.

I don't know of any setting to stop that.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

In this case I'm wanting to draw on top of a screenshot full screen, to annotate for a screencast. So with the canvas/image size being the same as the monitor, my brush bumps up against the edges frequently and even though there is nothing else beyond the canvas it scrolls anyway.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

OK I've got it.  That auto-scroll thing, but I have always thought that was an operating system thing because I thought I'd come across the same behaviour in other applications.  I tried

Turning off Overscroll in Preferences.

Both states of the keyboard scroll lock.

Locking the layer's position.

Toggled the Windows (I know the OP is using a Mac) Inactive Window scrolling in mouse settings

Sorry, I couldn't stop it happening

Has anyone checked the Feedback site to see if it has been raised before?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Hi Trevor

I did a quick check on the feedback site and didn't turn anything up.

Geddesign99  You can submit a feature request here :

Photoshop Family Customer Community

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Are we sure it is not OS related Dave?  I have a strong feeling that the same behaviour happens in other apps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Hi Trevor

I just tried MS Paint and Powerpoint. Neither of those do it

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

I can't get that to happen at all with the brush. It does happen with some of the selection tools and when drawing shapes, but not the pencil or brush whether zoomed in or not. Could this be a function of the graphics card driver? I wonder what happens if GPU acceleration is turned off?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

I tried that earlier Terri. No change.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Terry you need to be zoomed in far enough for the image to overspill the screen, and hold down the shift key while brushing towards and off the edge of the screen. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Blimey Trevor - you're up early (or late ) !!!

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2017 Aug 12, 2017

Copy link to clipboard

Copied

davescm  wrote

Blimey Trevor - you're up early (or late ) !!!

Dave

I'm getting up in the middle of the night to see if Trump and Kim Jung Un have started WWIII between them.

I thought this German magazine summed it up nicely, except it is too scary to be funny.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 12, 2017 Aug 12, 2017

Copy link to clipboard

Copied

How America ever elected a misfit like Trump I'll never understand. Anyone with sense can see what he's up to, distracting from the investigation into his financial ties to Russia. All this is going to do is isolate the US from it's allies. It's hard to have any respect for the US while Trump and his cronies remain in power. I don't know about New Zealand and Australia if Trump attacks Korea, but the UK won't get involved at any cost. and that goes for the rest of Europe. So if he triggers conflict with the Chinese , who do have nuclear weapons that can hit the US, he and the people who voted for him only have themselves to blame.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

Thanks Trevor

Yes I can reproduce it now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

You could use Floating Document Windows.

Photoshop CC>Preferences>Workspace and uncheck Open Documents as Tabs

or with an already tabbed document go to Window>Arrange>Float in Window

The image will still pan, but since Floating Document Windows won't overscroll it will only pan to the edge of your image.

Just don't check Overscroll in the Preferences>Tools.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2017 Aug 11, 2017

Copy link to clipboard

Copied

I really appreciate everyone trying to help figure this out!

Jeff: that almost works, but as soon as you go View > Screen Mode > Full Screen Mode then the pan behavior comes back.

Trevor & Terry: the pan behavior happens in Full Screen Mode even when your document is not zoomed in. Once brush gets close to edge of the photoshop app, it pans like crazy 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2019 Jan 10, 2019

Copy link to clipboard

Copied

I have same problem. Drawing in fullscreen, really annoys.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

I am also having this problem, I hope we get a solution

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

LATEST

This was driving me nuts too. Is this not the Overscroll feature? It can be turned off in Preferences > Tools.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines