• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How to stop adding " copy" to file names?

Participant ,
Feb 06, 2012 Feb 06, 2012

Copy link to clipboard

Copied

First off, I don't mind the save as a copy feature. If I have a psd file with layers and smart objects and such, and I Save As > JPG, I don't want the jpg open, I want the psd open. I like how PS does that behavior, but I don't like how that jpg gets " copy" added to it's file name. Yes it's easy to remove, but I'm using a batch action on over 300 pictures, I don't feel like renaming 300 jpg's. Yes it's supposed to be a safety net, but I basically never work from jpg's as original's, and if for some reason I do, I set them as read only and copy the files off to a safe location, so I don't need it.

I know it's possible because my old school's computers with photoshop CS5 never saved jpg's with copy in the file name. So, how do I stop PS CS5 from adding copy to my file names? Because I need photoshop to not add copy to my file names on my work computer (and it's my old school, can't use their computers or ask someone why it's like that).

Views

53.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Adobe needs to be sensitive to workflows and quit forcing users down a road I don't want to take. This copy "feature" is a complete aggrivation and counter productive to an easy workflow. I know it's easy to get rid of the copy in the filename but only if it's in a directory that doesn't already contain the same file that I'm trying to overwrite. Why can't it be smart and save a copy only if the file already exists in that directory vs. creating a copy regardless if you're saving a jpg and ask to overwrite or not as a save all with overwrite or ask on every save. Capture One is coming on strong and has a great UI.  Every time I have go fart around with removing & renaming files it makes me do more in Capture One.   

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 13, 2013 Jun 13, 2013

Copy link to clipboard

Copied

Hey everyone, I found a solution for this, You just have to choose "Save for web and Devices" instead of "Save As" ..then select,JPEG ( or whatever the file extension you need) and then hit save. And the file name will not be changed, so please remember to give a new location while recording the action.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2013 Oct 18, 2013

Copy link to clipboard

Copied

Doing that Ruby will remove the path if you need it in the JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

Did anyone found a solution to this problem? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2014 Nov 04, 2014

Copy link to clipboard

Copied

This works for me in CS6...

Ctrl + Alt + S = Save: As a Copy TICKED

Ctrl + Shift + S = Save: As a Copy UNTICKED

HTH.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

Remove all alpha channels from the channels options. Once removed it allows you to save out a jpg without adding the "copy".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

Are you using Photoshop Elements?  A friend of mine using Photoshop Elements sends me JPGs and every one of the file names has "copy" in them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

I'm using Photoshop CS6/CC. If the image isn't flattened the default for Photoshop is to append "copy" to the end of the file name. In my instance I flattened the file but the alpha channel was preventing it from saving without copy.Once channel removed it saved out perfectly

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2014 Dec 20, 2014

Copy link to clipboard

Copied

Okay, since this is still not resolved in almost 2015, gonna add my solution here. Actually i never found consistency about this auto-adding ' copy' behavior, it may suddenly stop doing this even if you use that legacy 'Save as copy' menu via cmd/ctrl+ALT+S shortcut (which should be removed already in CC 2014) with a checkbox 'As a copy' already checked, which causes the problem, as some users here have suggested.

But i found that is STILL adds ' copy' every time even if i use cmd/ctrl+SHIFT+S when recording an action to save as .png. The solution i found is that your .psd and .png file must have different names (to be 100% sure even put them in different folders), then it works as i want it to.

I have a icon_sprite.psd file in my website root folder and just want to update sprite.png in /images folder, without flatting it out, removing layers and stuff, that really makes no sense. Recorded an action pointing to /images directory, saving with a different name, and FINALLY it worked, it just overwrites /images/sprite.png as it should, without adding ' copy'.

I guess there is a bug which make PS think like there is a file with that name already, and it adds ' copy', because this is the file being edited. But this is incorrect, since it doesn't look at the extension.

May be you don't even have to put both files in separate folders, but like i said there's no consistency, so i can't be sure. May be it'd get fixed in CC 2020.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2015 Apr 06, 2015

Copy link to clipboard

Copied

Hi, for anyone who is having the same problem I think I have solved it.  If you set a Destination in the Automate - Batch menu, that'll save without the copy.  Worked for me anyway.  Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

I'm pretty sure I found a quirk (bug?) in Photoshop CS6 regarding the Save As Copy inconsistency when using automation. Setting a destination in automation will not always work.   If you open a PSD file that is flat, automation that saves with dialog will not restrict to the 'as a copy' mode.  With layered PSD files, even if flattened just before using automation, saving will be forced to the 'as copy mode', and the save destination will not be remembered for the next save.

I would argue that since I am saving a .jpg every time with my automation, that I should not have this enforcement.  When I want to save the same file to more than one location with automation (with dialog enabled) Not only do I have to rename the file again, but I have to navigate again to a far away folder.

This restrictive behavior is not enforced on files that were already flattened before opening, or on new files created, flattened and saved.  I suppose there is not great way to handle all of this, but I would think if I'm saving .jpgs I should be able to do whatever I want, since this is not my source image.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2015 Jul 09, 2015

Copy link to clipboard

Copied

My solution is to let PS add the word 'copy' to the filename because that's just what it wants to do by default.  Then go into the folder in Bridge - select all the files with 'copy' appended to the filename - right click and choose 'Batch Rename.  Choose Preset: 'String Substitution'.  Under 'New Filenames', Find: " copy" (with the space) and leave the 'Replace with:' blank.  Check the preview down the bottom of the window and you'll see that the word copy is removed.  Yay!!!

I am running Windows 7 but assume this will work in any OS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2015 Aug 05, 2015

Copy link to clipboard

Copied

It happens to me when I record an action in an open .psd file to save as .jpg in another folder, and then close the .psd file.

The first one (recorded) works without adding "copy" at the end of the file name.

But if I replay the action on other .psd files, then it adds the "copy" string at the end and it doesn't add the ".jpg" extension too... pretty weird.

I managed to make it work by recording the action once and then using the File > Automation > Batch... for all the other files using these properties:

Action: your recorded action for saving .jpg

Source: open files

Destination: folder (choose yours)

"Override action "save as" command": checked

Filename: default (file name and extension)

Hope it helps!

Kudos

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2015 Aug 09, 2015

Copy link to clipboard

Copied

Great!  That works for me.  Thanks for finding this solution to the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2015 Aug 26, 2015

Copy link to clipboard

Copied

There's no way to save a JPEG file as 16-bit because the format doesn't support 16-bit. So before you save your 16-bit images as jpg you have to convert them to 8-bit....easy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 10, 2016 Mar 10, 2016

Copy link to clipboard

Copied

So...   I've been outputting a load of images in preparation for web use.  And I know that this " copy" annotation occurs, there's no bug, it just happens whenever I save down anything to a single layer file using the Batch Automate command.  Today I needed to output a load of files for a web project, so file names needed to be exact.  After a quick google, I came across this discussion...  and quickly decided that the quickest way to do this was using an external program to rename the files, instead of spending hours giong through options and menu's and testing different methods in Photoshop.

I used the batch automate to convert a folder full of PSD's, Jpg's, PNG's and TIFF's into a folder full of JPG's - all with the " copy" added onto the file name.  I downloaded and ran "Bulk Rename Utility" (google it if you want it, comes straight up), selected the folder, typed " copy" into the Find section, and left the Replace With section blank...

Hey presto!  I had quickly and easily corrected all my filenames, without any scripting, timewasting, photoshop-menu-digging etc!!

I know it's not exactly the answer to the problem, but it's another way around it and I thought I'd recommend it as a simple, easy, and pretty much fail-safe solution to this problem.  Hope it helps.

Tom


Regards from the Armordillo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2016 Jul 09, 2016

Copy link to clipboard

Copied

After clicking clicking File > Automate > Batch... look for a checkbox inside the Batch dialog box that says 'Override Action "Save As" Commands', make sure this checkbox is activated. Now even though there's a Save As step within your action (which was necessary for you to specify that the file be saved as a jpeg) it will just be saved and the old file will be updated and saved with whatever steps were in your action.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2016 Aug 11, 2016

Copy link to clipboard

Copied

First, let me apologize if I missed someone else posting this same answer. Depending on your workflow, a reasonable workaround, albeit not a real solution, is to create and output your modified files to a sub-folder (created first by hand). With the copy option unchecked, the action will output files with their original names without "copy" appended. After processing you can then select and copy them back to your original working folder.

...Barry

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2016 Nov 02, 2016

Copy link to clipboard

Copied

I have had the same problem as well and it has been driving me nuts as I frequently use Batch to process large quantities of images. I finally found the solution. INTEGRATE A FLATTEN COMMAND IN YOUR ACTION. Make sure to use an image that is not flattended when recording, otherwise this command will not be an option.

When you use the Batch command after this, it should not add copy to your file name - which of course disrupts the work flow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2016 Nov 02, 2016

Copy link to clipboard

Copied

Yes, the flatten action works well at times but since I work in 16-bit Adobe color, Photoshop still insists on a "copy" when you are saving an 8-bit sRGB file.  I don't understand this.  Anytime it's a .jpg it IS a copy and it can be re-created.  If I'm saving a copy of another .PSD file then by all means add the "copy". 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2016 Nov 02, 2016

Copy link to clipboard

Copied

I just tested out your scenario, generating both Adobe RGB and sRGB in 8 and 16 bit files and you are right. It's smooth sailing as long as it is a flattened 8 bit file. When dealing with 16 bit files, it will include the "copy" in the file name.

It doesn't make any sense.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2016 Nov 23, 2016

Copy link to clipboard

Copied

I was able to fix this same  problem today.  It turned out the files I was processing were saved as 16 bit.  I resaved them as 8 bit and ran my action set and it did not include the copy tag.

Hope this helps.

Check to see if your workspace is running in 16 bit. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2018 Feb 22, 2018

Copy link to clipboard

Copied

Sorry for necroposting (but this thread is the first result in Google, so hopefully it'll be helpful for someone else), but converting to 8bit RGB & flattening sometimes doesn't work.

I found a stupid, but simple workaround.

Create and save preset for "New file" dialog with 72ppi / RGB / 8bit / transparent background

Record the action to:

- flatten image

- select everything

- copy

- create new document with a preset you've created earlier

- paste

- save as... ("as a copy" checkbox should be active now - untick it)

- close that new document

- undo (to un-flatten your original image)

This worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2018 Mar 20, 2018

Copy link to clipboard

Copied

Using Photoshop CC (19.1.0 release)....

What I found is this:

When working on a JPG file I create one or more additional layers.

Then, I choose "File -> Save As..." (cmd + shift + S) and select file type of JPG.

If I do that, then the checkbox for "Save as Copy" becomes automatically checked, and greyed out.

If you want, you can manually backspace the " copy" that got appended and then it will let you save over the file anyway.

It will still prompt you to confirm if you really want to overwrite the file.

OR....

Instead if I first flatten the image, and then just do a "File -> Save" (cmd + S), then it allows me to save over the image without prompting first.

(or cmd + shift + E for "Merge Visible," since there is no keyboard shortcut for Flatten Image.... )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I hate this new update with "copy" being added to the file name! It just adds another step. I liked it better when all options were under one scroll bar. It seems updates lately just make things worse not better. Argh. Hopefully they can update this again to where we turn that off preferences or something (to opt out of the additional word) I prefer to name as I go. It is already a different file with the ".jpg" ".psd" etc at the end so its not saving over. I dont get the logic behind it.  If anyone knows a way I can turn that off I would be forever grateful. Thx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines