• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

How to stop auto select 'TEXT LAYER' ?

Enthusiast ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

Dear all,

i have googled it, and untill now, i can not found the answer, may be Google Artifical Intelegent (AI) doesn't know what i mean.

---

I have auto select layer off, and everytime i use text tool to write a text, it always go to specific text layer even i have created a new layer. How to stop this behavior?

I want when i use text tool to write text, it stay in that current layer, not go to another text layer beneat it. Thanks.

-Office : Adobe || Home : Resolve-
TOPICS
Windows

Views

252

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Feb 04, 2023 Feb 04, 2023

Hi, @Eko Wardoyo and welcome back in here! A video or an annotated screenshot of the problem might help us help you faster.

 
Let my give you the solution to what I guess is your problem: In order to create a next text layer next to an existing one, shift-click with the text tool. 
It will force the creation of a new text layer and avoid re-selecting the previous one.

More text tool tips:  https://jkost.com/blog/2020/09/30-tips-tricks-and-shortcuts-for-working-with-type-in-photoshop.html

Votes

Translate

Translate
Community Expert , Feb 04, 2023 Feb 04, 2023

@Eko Wardoyo 

 

  • Text will never go into a shape
  • Your cursor is an I-beam. It goes into the only existing text frame — watch for the dotted line rectangle
  • You do not nee to create a new layer for type — clicking or dragging with the type tool creates a layer

 

What you need to do is hold down Shift to force a new type layer, then click (or drag) and type. 

 

 

Jane

 

Votes

Translate

Translate
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

@Eko Wardoyo 

 

One reason this happens is that the frames overlap. We haven't seen your file so we can only guess.

  • You can double-click the "T" icon in the layers panel to select the text in the layer you want
  • or you can lock the layer that you keep clicking in
  • or you can try reordering the layers in the Layers panel
  • or if you are using paragraph text you can resize the frames (type tool) to make sure they don't overlap (resizing point text will resize the text itself)

 

Do any of these help? If not, please give us more information and a screenshot.

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

Hello!

Does it still do the same if you are hitting the "ESC" key before choosing the text tool the second time?

ESC means it unselects the initial type frame, and therefore opens a new one when you click with the text tool.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

Hi, @Eko Wardoyo and welcome back in here! A video or an annotated screenshot of the problem might help us help you faster.

 
Let my give you the solution to what I guess is your problem: In order to create a next text layer next to an existing one, shift-click with the text tool. 
It will force the creation of a new text layer and avoid re-selecting the previous one.

More text tool tips:  https://jkost.com/blog/2020/09/30-tips-tricks-and-shortcuts-for-working-with-type-in-photoshop.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

One other thing to mention is to look at your cursor. If it is an I-beam, you are about to click in a current text frame. If it has a dotted-line rectangle around it, you are about to create new text.

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

Thanks all for reply @jane-e @PECourtejoie @Imaginerie

Here is 1 minute of video of what i mean. thanks so much.

https://youtu.be/-CwTNaGkWJU

-Office : Adobe || Home : Resolve-

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

@Eko Wardoyo 

 

  • Text will never go into a shape
  • Your cursor is an I-beam. It goes into the only existing text frame — watch for the dotted line rectangle
  • You do not nee to create a new layer for type — clicking or dragging with the type tool creates a layer

 

What you need to do is hold down Shift to force a new type layer, then click (or drag) and type. 

 

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

Hi @Eko Wardoyo 

Activate your Rectangle layer before selecting your text tool.

 

Then pay close attention to the cursor. It changes (depending on its position in the document) over the existing text field to the text cursor, over the path of the rectangle to the path text cursor and within the rectangle to the area text cursor and at free places to the new text cursor.

 

If, however, as in your case, a new empty layer is activ, then only the new text cursor works. But the position of the cursor must then be outside existing text fields.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

... unless you shift+click...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

That's right - but @jane-e has already mentioned that.
😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

As well 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied


@pixxxelschubser wrote:

That's right - but @jane-e has already mentioned that.


 

Actually, I merely repeated it after watching the video! 😊

 

Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

As Jane said, you cannot put text inside a shape, but you can, inside a path. Create a path instead of a shape (look in your option bar), duplicate, and hide a copy.

With the text tool, Shift+Click inside that Path to create area text contained within that path, without activating the text in the back.

You can then Unhide the back path, and convert it into a shape that you can now customize.

(Here's hoping I have all the correct steps, kids are watching a DVD on my Mac...)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

LATEST

Thanks so much for you all, solved.

-Office : Adobe || Home : Resolve-

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines