• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Issue with justifying text

Community Beginner ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Hi, I'm trying to justify text in my photoshop document but, after I do, the right edge is not fully straight. I've attached a screenshot of what I mean. I've tried ticking the hyphenate box too but that doesn't help. It's strange because when I click on the justify text button it puts the text completely justified (like I want it) for a split second but then it defaults back to being not quite justified. Any help would be much appreciated.

 

I'm on phtooshop version 23.3.1 on a mac (OS 12.3.1)

TOPICS
macOS

Views

2.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Check to see if you have carriage returns, and replace them with spaces.  Better still, use a text box and type into it.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Thanks. There aren't any returns among the text, I've just checked. It's a big document so I'd rather not type it all out again in a new text box. When I copy the text into a word document and justify it there it looks fine. It's very strange that it's not fully justifying the text in photoshop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

Word is notorious for messing up formatting when transferring to other apps.  You can use the Ctrl Space trick to remove the formatting, or paste it into Notepad and copy it back to Photoshop.  But I would have thought you could still just paste it into a text box. Try doing that, and chhanging the width of the text box.  That will show any hard returns for sure.  

 

Hey, I have just realised that you might not be using the correct icon going by your screen shot.  It's the one on the right

image.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Thanks again. I've tried the 'Justify all' and all the different justify types many times but none of them work (it's actually the 'Justify last left' I want so the last line isn't stretched). I've tried removing the formatting, copying and pasting it into notepad then pasting it back into photoshop. I've tried setting it up in a new photoshop document, changing the text box boundaries, changing the font, the size... nothing works. 🤷‍:male_sign:  Not sure what to do. It's so odd.  

 

What's the ctrl space trick?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

@defaultsvqcgolqgv74 

 

Trevor meant to say "last line left", the first of the four.

 

Here is the help page from Microsoft on clearing formatting, but it's for Windows. Try Cmd+Space instead. The video also shows where the "Clear Formatting" button is.

https://support.microsoft.com/en-us/office/video-clear-formatting-01dff891-ef99-4d8f-8982-d7f05cffc1...

 

To clarify: are you drawing a text frame, then pasting (paragraph text) or clicking and pasting (point text)?

 

Can you also select some of the text and show a screenshot of the Paragraph panel menu? Maybe there is a setting in there.

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Hi Jane, thanks for the response. I'm drawing a text frame and then pasting the text into it. Here's a video showing what happens. It does actually look right when I first paste it into the text box and justify the text, but when I change it to the font I want (Alegreya) it goes strange again. The same thing happens if I change it to any other font and if I change the text box boundaries. I even tried writing out the text from scratch in a new text box but the same thing happens.

 

I've also included screenshots of the paragraph panel and character panel.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

This video shows what happens when I select 'justify all'. It looks right for about a second and then it reverts back to being uneven.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Oh my gosh, I've finally figured out what the problem is! For anyone who stumbles across this issue in future, you have to click in the top right of the paragraph panel and select "Latin and East Asian Layout". Screenshot attached. Phew! 😅

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

 

So happy to hear this, @defaultsvqcgolqgv74 ! 

 

Reading back through the thread, when I wrote, "Can you also select some of the text and show a screenshot of the Paragraph panel menu? Maybe there is a setting in there," you only posted images of the panels themselves, not the menu. We could have caught it earlier!

 

Cheers

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

I had no idea the additional panel menu existed. I thought you just meant the main panel. Thanks for your help. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

LATEST

@defaultsvqcgolqgv74 

You're welcome, but maybe I should have identified the panel menu as being the four lines in the upper right, and I apologize if it was not clear.

 

All the panels have menus, so investigate the others when you have a few minutes here and there. Each panel menu applies to what can be done in that specific panel. 

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines