• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Magic Wand tool selects everything

New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

I have a single layer one colour PNG file and I'm trying to use the magic wand to select part of a logo to change the colour, however, the entire layer is being selected.  I'm in Photoshop 22.0.0.  I've tried changing the tolerance, selecting 'sample all layers', I've restarted Photoshop and reset the default tools... nothing seems to be working.

 

Any ideas Community?

Views

5.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 10, 2020 Nov 10, 2020

I don't see any selection at all?

 

What you might try, though, is to lock the layer for transparency (the first of the five lock buttons in the Layers panel.) Then fill or paint the layer — any transparency will be locked and untouchable.

 

~ Jane

Votes

Translate

Translate
Adobe
Guest
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Hi

Can you post the png file or a screenshot of Photoshop with all the pertinent panels opened

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Screenshot 2020-11-10 at 17.51.42.png

 

 Here you go!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

I don't see any selection at all?

 

What you might try, though, is to lock the layer for transparency (the first of the five lock buttons in the Layers panel.) Then fill or paint the layer — any transparency will be locked and untouchable.

 

~ Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Sorry Jane, same image with the attempted selection. I've clicked on the black letter D here but whatever I click on it selects the whole layer...

 

Screenshot 2020-11-10 at 18.05.09.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Neat trick with the transparency lock mind you... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Hi

 

It's odd about the Magic Wand. Possibly it's the low tolerance of 2. Try resetting it by right-clicking the tool in the options bar (not Tools panel) and Reset tool and see if it works with the default tolerance of 32.

 

Also try holding Cmd and clicking on the thumbnail in the Layers panel to select all the pixels on the layer. (A newer method is to right-click the layer and choose Select Pixels.) Does that work?

 

I have to say that the Magic Wand would be my third choice here, because you would have to Shift+Click each shape. But, still, it is supposed to work.

 

~ Jane

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

So the CMD click on the thumbnail works but changing the tolerance does nothing.  Neither does the reset tool option.  I'll reboot the system tonight and no doubt it will mysteriously correct itself! 🤣

 

Thanks for your help, I'll use one of your other workarounds!  Cheers...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

You're welcome, Martin, and I'm glad you've found two ways that will work for the immediate issue. 

 

There is something flakey about your Magic Wand tool, though. Try it in another document and see if it works elsewhere. As a 20-year PS veteran, you know how it should be working.

 

If it fails in other documents, and if rebooting does not work, then consider resetting Preferences, as they may be corrupt. Go to Photoshop > Preferences > General > Reset Preferences on Quit, after first backing up any customization such as Actions, Gradients, Custom Shapes, etc., as it will give you a clean install.

 

~ Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

I cut out the face with the Rectangular Marquee, put it on it's own layer, selected with Magic Wand and filled with Edit>Fill>Foreground Color.  Is that what you are trying to do?

Screenshot-2020-11-10-at-18.05.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Yeah, that doesn't work for me, I'm afraid.  Not sure why, I've been working in Photoshop for over 20 years and the Magic Wand has never let me down for simple one colour selection, especially on a transparent background layer... I've used Jane's transparency lock workaround this time and for anything more complex I wouldn't use the wand anyway... still an odd one though. Cheers!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2023 Nov 11, 2023

Copy link to clipboard

Copied

I know it's been a while since you posted this, but I just ran into the same thing. Simple image, only two colors, regardless of what I did, the Magic Wand selected everything.

 

For me, it turns out I had hit Q instead of W on my keyboard while looking at the image, and I turned on Quick Mask.

 

I was losing my mind ... until I saw "Quick Mask" beside the file's name (on the tab for the document). I vaguely remember seeing the red mask overlay, but in my haste, I guess I had hit W right after and went along my obliviously merry way.

 

I hit Q again, and voila. I'm no longer selecting every pixel with the wand.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 29, 2023 Nov 29, 2023

Copy link to clipboard

Copied

@DistinctlyMe  This helped me! Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2023 Nov 30, 2023

Copy link to clipboard

Copied

Hey! Thanks for this... you know, that may have been my issue too as this issue never raised it's head again!  Cheers...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

LATEST

That was the fix for me! quick mask was accidentally active. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines