• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Merge layers while keeping blend modes

Community Beginner ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

What once seemed to work for me now isn't.... (working in Photoshop 24.0.1, MacOS 11.4)
We know that simply merging layers which contain blend modes does't work well as the layer(s) with a blend mode turn to normal layers. What used to seem to work well (command + option + shift + E to create a "snapshot" layer of all visible, now doesn't seem to be working either.

 

What I'm doing is silhouetting out subjects, retouching out the bounceback color casts on a layer in color or hue mode, and then replacing the background. I'm handing some images off to another designer, so best to have the object on a single layer w/a transparent background.

 

My method used to work great! Now it's not. Alternate suggestions?

TIA

TOPICS
macOS

Views

3.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Blend modes are there to define how a layer interacts with layers below. When you merge layers, there is nothing to apply a blend mode to.

And if you use the command-opt-shift-E with multiple content layers, it works correctly to create a new layer. A new layer is NOT created if the top layer is empty, that is the layer stamped into.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Could you please post screenshots taken at View > 100%with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

 


We know that simply merging layers which contain blend modes does't work well as the layer(s) with a blend mode turn to normal layers.

They are turned into one Layer and one Layer has one Blend Mode. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Here's the layered version and the layer created using the command-shift-option-E shortcut. You can see how that combined layer gets plugged up. I did NOT have the black background visible when I created the layer; just the masked-out cat and the retouching layer. (as that's how I need it)
I'm using a blend layer on "Hue" to neutralize the purple bounceback light

Now, this DOES look correct when I include the background to create the layer, so perhaps that's part of this particular issue....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

apologies..uploaded the same image...here's the which was layer created (background added for this image

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Hi, @tkeiger I removed the duplicate for clarity.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 18, 2023 Feb 18, 2023

Copy link to clipboard

Copied

Again: 

Could you please post screenshots taken at View > 100% with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

The plural »screenshots« is meant to indicate that at least two screenshots are wanted – pre- and post-merging. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2023 Feb 18, 2023

Copy link to clipboard

Copied

I rather did that 🙂 see images above: both are at 100%. The "Layer" graphic is the one with the (new) merged image; the "retouch" one is the layered version. Only one layer w/a blend mode (hue)

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 19, 2023 Feb 19, 2023

Copy link to clipboard

Copied

LATEST

@tkeiger wrote:

I rather did that 🙂 see images above: both are at 100%. The "Layer" graphic is the one with the (new) merged image; the "retouch" one is the layered version. Only one layer w/a blend mode (hue)


You have not provided the screenshots I asked for so again: 

Could you please post screenshots taken at View > 100% with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible

 

What are the Blend Modes of the Layers you are merging? 

 

Alternatively you could provide the unmerged image. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

quote

Now, this DOES look correct when I include the background to create the layer, so perhaps that's part of this particular issue....


By @tkeiger

Yes, a blending is the result of the mix of several layers, remove one of them from the equation, and the result is different... 1+2+3=6 != 1+2

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Hey,

 

I'm not sure if you can go back but Create a New Layer at the top of your Layers Palette before you merge. Then select that Layer and hit command + option + shift + E as you did before.

 

This should give you a merged Layer on top with all the Layers below still in tact. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

As I noted. If you have an empty layer, content is stamped into that. If you don't have an empty layer, a new one is created. Same result.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2023 Feb 18, 2023

Copy link to clipboard

Copied

and I have done both with and without and empty layer....same results.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Have you tried using Smart Objects? I'm happy to elaborate if needed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2023 Feb 18, 2023

Copy link to clipboard

Copied

I have, thank you.
See this is what is baffling to me: I've successfully done this far too many times over the past few years. And now it's not working.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines