moving a selection without having layer selected returns "programm error"

New Here ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

steps to replicate:

  1. create a selection
  2. switch to move tool
  3. click into empty void below all layers to select none
  4. press arrow keys to move content of selection

 

what happens:

Unbenannt.jpg

above is german the translation is:

Could not move the selection, because a programm error accured.

 

what I expected:

simmilar error as when you try to move a empty selection or try to use a brush without having a layer selected.

TOPICS
Windows

Views

37

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

Hi. Can I ask why you're trying to do this with no layer selected? There's no need. When you have an active selection you can move that selection IF you're still on any selection tool. When you switch to the Move tool - Photoshop tries to move your pixels. If you have no layer focus, there are no pixels (and not even a lack of pixels) for Photoshop to move.

So, in the future, if you want to move your active selection, simply stay on the selection tool, until you're ready to take action on pixels. 

S_Gans
Adobe Community Professional / Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

LATEST

I was able to reproduce and agree it should probably do something else to let you know you don't have a layer selected.

 

Illustrator has a UserVoice website you can report items like this, Photoshop I believe does not anymore, though they did as I remember posting there.

 

But you can submit a bug like this here, or I might be able to move your post there.

https://community.adobe.com/t5/forums/postpage/board-id/bug-photoshop

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines