Painting on MacBook Pro track pad slips

Adobe Community Professional ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

I ignore my own advice and use my trackpad on my computer - I'm too lazy to switch computers or grab my wacom. While painting in photoshop - usually on a mask - it always "slips". It doesn't take long, all of a sudden my cursor zips across the screen creating a straight line way outside of what I'm painting. It's annoying! Is it a setting I can change? I've looked in the system prefs and don't see anything. 

Melissa Piccone | Adobe Certified Instructor | Adobe User Group Manager
TOPICS
macOS

Views

78

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Oct 14, 2021 Oct 14, 2021
A few thoughts: In Trackpad Preferences, I keep the Trackpad speed slider all the way to "Slow" and uncheck any gestures I don't use. If you suspect hardware issue with the trackpad, check his guide: https://techvilleonline.com/curse-of-the-crazy-cursor-what-to-do-if-your-mac-cursor-keeps-jumping-around/ In Photoshop, see if these help. Resetting Preferences might be an idea even though I hate having to restore setttings and custom workspaces. It might just clear up the problem. Lock L...

Likes

Translate

Translate
Adobe Community Professional ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

A few thoughts:

In Trackpad Preferences, I keep the Trackpad speed slider all the way to "Slow" and uncheck any gestures I don't use.

 

If you suspect hardware issue with the trackpad, check his guide:

https://techvilleonline.com/curse-of-the-crazy-cursor-what-to-do-if-your-mac-cursor-keeps-jumping-ar...

 

In Photoshop, see if these help. Resetting Preferences might be an idea even though I hate having to restore setttings and custom workspaces. It might just clear up the problem.

 

 

 

Lock Layer position. You can still paint.

Screen Shot 2021-10-14 at 8.22.05 PM.png

In Photoshop Preferences > Tools, I uncheck these, and if I can work at less than "fit to screen", I check "Overscroll" on, and it holds the image in place.

Screen Shot 2021-10-14 at 8.26.28 PM.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

The slow speed is making me crazy for everything else but I'll give it a shot. 

 

Melissa Piccone | Adobe Certified Instructor | Adobe User Group Manager

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Ok.  I have a mid 2012 MBP and don't seem to notice this, Melissa. I'm running MacOS Catalina.

 

Another thing: Under Security & Privacy > Accessibilty, be sure Photoshop 2021 is on the list and checked on.

 

If resetting the nvram or Preferences does not help, You may want to check with Apple if you have time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

The slower tracking speed seems to be working - I only spent a few minutes trying it out, but it's didn't jump at all. If it starts up again, I'll reset the nvram. 

Melissa Piccone | Adobe Certified Instructor | Adobe User Group Manager

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Good to hear that you are getting results. If the slow speed is distracting, try bumping up the tracking speed until you get the "jump" again.

 

Gene

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 16, 2021 Oct 16, 2021

Copy link to clipboard

Copied

LATEST

While researching another problem, I came upon this subject, which has a few more ideas:

https://www.lifehack.org/articles/technology/how-to-diagnose-the-phantom-cursor-issue-on-your-mac.ht...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines