Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop 22.4.2 on new MacBook Pro with M1 chip: screen flickers and image disappears, black screen

New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I just purchased the MacBook Pro last week and downloaded all the latest Adobe Illustrator, Photoshop and InDesign. Photoshop 22.4.2 is not working well-- open an image and the screen within Photoshop flickers like crazy and turns black. Photoshop stays open, doesn't crash but you can't see anything. I tried adjusting image size and saving and it let's you do that but you can't see anything. I've tried quitting and restarting laptop but same issue continues. Is there something in Preferences>> Performanace that I need to adjust or is this going to be an on going issue? Any help is appreciated.

TOPICS
Bug, Mac, Performance, Problem or error

Views

694

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 10, 2021 Jun 10, 2021
Go to preferences/Technology Previews then enable the option to Deactivate Native Canvas.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Go to preferences/Technology Previews then enable the option to Deactivate Native Canvas.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2021 Jul 06, 2021

Copy link to clipboard

Copied

This works. What exactly is going on here?  I had the same issue.  I discovered that unchecking Preferences->Performance "Use Graphics Processor" also fixed things.  This is a much better solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Unchecking Use Graphics Processor turns off enhanced functions in Photoshop and is not a better solution. 

This post shows a list of features disabled when you turn off Use GPU

https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

By "this" I meant your solution, not turning off the GPU.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

LATEST

Thanks so much! You're a lifesaver. I've been looking for a solution for months now and nothing worked but this.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines