Photoshop 22.5.1 and Canon Print Studio Pro - Plug in not loading

Community Beginner ,
Sep 15, 2021 Sep 15, 2021

Copy link to clipboard

Copied

Since the latest upgrade to Photoshop 22.5.1 Canon Print Studio Pro no longer works.

 

Tried removing and reinstalling - its there in the correct folder etc - but when i click on it to start a print it doesn't fire up.

 

Running Mac OS Big Sur at latest version

TOPICS
macOS

Views

8.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Sep 23, 2021 Sep 23, 2021
I have spoken to Canon support in the UK and they have replicated the error. Looks like we will have to wait for a patch/updated plugin - the latest version of Big Sur seems to have broken it.

Likes

Translate

Translate
New Here , Oct 26, 2021 Oct 26, 2021
Today, 26/10/21, Apple have issued an update to Mac OS Big Sur. It is Mac OS Big Sur 11.6.1. If you install this update, then you should find that Canon Print Studio Pro will now be working as it should do.

Likes

Translate

Translate
Adobe Community Professional ,
Sep 15, 2021 Sep 15, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2021 Sep 15, 2021

Copy link to clipboard

Copied

I have indeed downloaded the latest version which is actually 2.2.5 for the Mac

I suspect it might be due an update to Big Sur and Canon might need to update the plugin

All other plug ins work fine - so can’t see it being a big fix… I hope

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 18, 2021 Sep 18, 2021

Copy link to clipboard

Copied

Same issue  here ! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

I have spoken to Canon support in the UK and they have replicated the error.

Looks like we will have to wait for a patch/updated plugin - the latest version of Big Sur seems to have broken it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 10, 2021 Oct 10, 2021

Copy link to clipboard

Copied

Still there is no patch or updated plugin, it is not work with BigSure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

I have the same problem has anyone found an answer to this? I'm also running Big Sur

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

The plug-in probably needs to be quarantined. See the section "Plug-ins not found or cannot be verified" here: https://helpx.adobe.com/photoshop/kb/plug-ins-photoshop-troubleshooting.html 


Senior Product Manager - Customer Advocacy - Digital Imaging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

reinstalling didn't help in my case. Lightroom is exporting but PSP would not start. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

Quaranting is not the answer - the plug is not causing problems with Photoshop running

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

My configuration: macOS Big Sur 11.6 - Photoshop Release 22.5.1.

Same problem with PPL, it doesn't work as a Photoshop plugin, but as "standalone" software.

A simple question: Apple and Canon talk to each other sometimes? I hope so, so we will see our problem solved very soon!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

I have the same issue, to print I had to save the files on tiff mode and load them manually on Canon Print Studio Pro. Prints came out with no issue, however I had to Force Quit Photoshop.

 

I also tried printing from Lightroom, and it works fine, so my guess the problem came from Photoshop update, as I printed 7 days ago and the photoshop update was done 5 days ago.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

I have the same problem. Big Sur 11.6 seems to have interfered with Canon Print Studio Pro. The plug-in doesn't launch PSP in Lightroom Classic. In Photoshop the automation freezes PS and I have to Force Quit it.

 

I've uninstalled and reinstalled all the currently available Canon software and the latest version of PSP.

 

It seems like the respective plug-ins are not actually launching the Print Studio Pro application (yes, it's a separate application.)

 

If you go into the Library folder on your Hard Drive (the top level one, not the one in your Username folder), and go to the Application Support/Canon/Print Studio Pro/Frameworks folder, you will see the Print Studio Pro app. If you click on it and try to launch it, it will not launch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

correct. Same behaviour as when lightroom tries to launch PSP plugin / module

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

I think Canon support is the place to get get this fixed, OSX Big Sur is quite dated now (released November 2020), it seems Canon are letting themselves get left behind with the Print Studio Pro SW. Maybe that means support is ending?

Mind you, whats wrong with printing straight from Photoshop using Canon's driver?

 

I hope this helps
neil barstow, colourmanagement net :: adobe forum volunteer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Hi NB,

 

I am not sure if the issue is Big Sur or Photoshop (who updated its version last week). The same pluging works well with Lightroom.

 

I have a question, how do you manage to print multiple images strait from Photoshop, so far I know you can only do one at the time, and if you are using a large paper as I use a Pro-4000?

 

Tks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

Hi, to make a properly controlled layout of various images on larger ppaer such as in your 17" Epson, I'd recommend InDesign.

I've often found auto nesting applications dont do as well as you can do yourself adding images to a suitable sized InDesign canvas 

 

Big Sur isn't going to change (until you install the next version) so your port of call for a SW fix is Canon. 

 

I hope this helps
neil barstow, colourmanagement net :: adobe forum volunteer
google me "neil barstow colourmanagement" for lots of free articles on colour management

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

Using the Print command in Photoshop Elements does not provide the same level of control over the finished product. For instance you do not have as extensive a selection of paper types (Canon) that you do if you use the Print Shop Pro plugin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

The only fix at this stage is to roll back MacOS to previous update, Canon Australia printing dept told me they havent heard anyother issues which I was supprised.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 10, 2021 Oct 10, 2021

Copy link to clipboard

Copied

After them informing me that I should reload the plugin, I did provide the same information to Canon USA, however after this I had no further feedback from them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 13, 2021 Oct 13, 2021

Copy link to clipboard

Copied

I have spoken to Canon US  (really not an easy task considering their broken  phone system ) and was told that they are aware but no idea when the  upgrade will be out.

 

The rep said something along the lines of "we don't know what apple or adobe are going to come up with). I guess he meant this require collaboration  with apple and adobe ?  

 

They just suggested to keep checking their website for a chance that maybe some day they will they will have and updated  version to download 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

the same problem with the print studio pro would not run with the plug in  photoshop 2021.

how to fix it.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

Sorry there is no solution until Canon release new firmware for PPL. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

I"m watchin this live zoom- - part of  Canon Printing Week-  The Pro-300 Workflow Demo

Dring the demoonstation they are using   Professional-print-layout-software         https://en.canon-cna.com/printers/inkjet/pixma/software/professional-print-layout-software/  -  mentioning the features which are supiriors to Print Studio Pro.  It  not competable  for the PIxma 100 though. .

 

Maybe Canon are just dropping support for Pritn Studio Pro? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

Yes, it doesnt work on Big Sur 11.6 even with the latest Canon 22.5.1 version which is the latest one. It is always a disaster when IOS is upgraded. have another computer running on Big Sur 11.5 and works fine even with the latest version of Adobe Lightroom. So not a Adobe issue. So, unless you downgrade your IOS to 11.5 you will not have the PlugIn working before Canon releases a new version. And that always takes time, unfortunatelly...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines