• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Photoshop commands not available (using actions)

New Here ,
Sep 17, 2017 Sep 17, 2017

Copy link to clipboard

Copied

I have some photo editing actions installed that I've been using for YEARS. Everything has been working fine all day. All of a sudden I start getting error messages that are saying "The command is not currently available".  I have no idea what is causing this issue. Someone please HELP!
Screen Shot 2017-09-17 at 7.46.19 PM.png

Views

21.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 17, 2017 Sep 17, 2017

Actions can record almost any action (command from menu) which you can perform in Photoshop. However, to use some command there are always some requirements like: active selection, layer in the Layers panel selected and so on. For example: you can not ask in step to create selection based on layers content if layer does not contains any pixel, it will display error message. Each step in action is individual command but you must ensure in previous step(s) that requirement is met. To fix your issu

...

Votes

Translate

Translate
Adobe
New Here ,
Sep 17, 2017 Sep 17, 2017

Copy link to clipboard

Copied

Other times I'm getting an error saying "Could not complete the command because the active layer is empty." This issue is really annoying.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2017 Sep 17, 2017

Copy link to clipboard

Copied

Actions can record almost any action (command from menu) which you can perform in Photoshop. However, to use some command there are always some requirements like: active selection, layer in the Layers panel selected and so on. For example: you can not ask in step to create selection based on layers content if layer does not contains any pixel, it will display error message. Each step in action is individual command but you must ensure in previous step(s) that requirement is met. To fix your issue you must expand action and action steps to see what is recorded, which step is causing error message and if that step or command requires something like pixels on layer then look at previous steps(s) to determine why that requirement is not met.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

I get a similar series of error messages when I open Photoshop without an file active, starting with the "Make"command.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

Which exactly messages, can you post screenshot with error message and Layers panel visible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

Screen Shot 2018-10-28 at 4.00.05 pm.png

This is followed by several other similar error messages.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

This is happening when you run/start Photoshop? Although I am not able to reproduce the problem my suggestion is to check File > Scripts > Script Events Manager and to remove any script/action associated with Start Application event.

Please see a screenshot with steps to remove event: select event then click Remove button and lastly click Done button to confirm and exit.

event manager.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

okay - that seems to have fixed it - thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

I also have this problem. Actions are bogged down by a succession of error messages

The command “Move” is not currently available.

The command “Make” is not currently available.

The command “Color Range” is not currently available.

The command “Fill” is not currently available.

The command “Levels” is not currently available.

The command “Desaturate” is not currently available.

The command “Invert” is not currently available.

Could not complete the command because the selected area is empty.

 

None of my paint effect actions now work. Could this be due to one overall setting problem? The error messages are soooo user-unfriendly, clearly designed by a programmer and not be a UX designer. really weak.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 26, 2022 Dec 26, 2022

Copy link to clipboard

Copied

did you get an answer for this? I am having this exact issue. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 26, 2022 Dec 26, 2022

Copy link to clipboard

Copied

Me too. Please give me an advice. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 26, 2022 Dec 26, 2022

Copy link to clipboard

Copied

The correct answer from Bojan still applies. The file's current state does not match the action step requirements.

 

To help resolve such issues, please provide a screenshot with the action panel open and with the steps expanded with the error message visible so that we can see which recorded step is creating the error.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I think it might be because you're running actions on a smart layer when the actions were originally recorded on a raster layer, or vice versa.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Hi, I'm having an issue as below, I check scripted manager and if it was a smart layer, but this message comes up in the middle of loading an action for the sparkles effect I bought from Envato, any help please?

 

Barry21762952j9qk_0-1677776579430.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2023 Jul 27, 2023

Copy link to clipboard

Copied

I have the same problem and also bought the sparkles action. Please help.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

I had the same problem, too, except with a "Rasterize" error. This started happening randomly when I ran a batch Automate command just after I opened the program.

Here's what fixed it for me: just create a new blank file, so that you're in an image editing mode instead of the program start mode. Then run the Actions. When I did that, Actions that were throwing an error just moments before started working perfectly!

It makes no sense, but hey, if it works, why ask why?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 27, 2023 Jul 27, 2023

Copy link to clipboard

Copied

@Barry21762952j9qk & @sheree31341972a9vs 

 

The file's current state does not match the action step requirements.

 

To help resolve such issues, please provide a screenshot with the action panel open and with the steps expanded with the error message visible so that we can see which recorded step is creating the error.

 

What is being expanded? A good guess is a selection. Is there a selection and if not, why?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2024 Jun 17, 2024

Copy link to clipboard

Copied

LATEST

Hi, I am having trouble understanding everything that is explained above. I have attached screenshots of my issue of "desaturate" and "fill" not available. What is frustrating is that my actions work, because they have worked. And suddenly one day they don't work and I can't figure out why. In my screenshots, my actions start at "Refine Edge and Quickmask", then after existing the quickmask I move on to the WHITE Background action. I attached screenshots so you can see the progress of the layer, the history, and the action step. After, the prompts appear, I click continue on both and it goes back to the first step "WHITE Background". Thanks for any help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines