PhotoShop CS6 - Lighting Effects Not showing

New Here ,
Jun 09, 2012 Jun 09, 2012

Copy link to clipboard

Copied

I know the question sounds like the ones you get all the time but in PhotoShop cs6 I can access the filter>render>lighting effects but when I click the lighting effect tab nothing shows and when I watch a tutorial and people open filter>render>lighting effects a adjustable thing appears on the layer which they can edit but I can not do this. Any help?

Views

88.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 06, 2014 Dec 06, 2014
The answer is even simpler than you think... You need to work in 8 bits mode to use the lighting effect. To do this select:Image/mode/8 bits/channeland it should work

Likes

Translate

Translate
Adobe Employee ,
Jun 11, 2012 Jun 11, 2012

Copy link to clipboard

Copied

Moving to Photoshop forum

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2016 Mar 22, 2016

Copy link to clipboard

Copied

Went to Preferences on my MacBook Pro 13" Retina (Early 2013)> Performance. The "Use Graphics Processor" was checked. I clicked the Advanced Settings button, changed the Drawing Mode to Basic, and retried it again... nothing. I tried some of the other solutions (e.g. went to images/mode and "8 bits/channel" was already selected. Tried seeing if my graphics card needed updated, but it has the current updates.


Out of options to get the Lighting Effects to work?


MacBook Pro - (early 2013)

OS X - El Capitan

Version - 10.11.4

Graphics - Intel HD Graphics 4000 1536 MB

Photoshop CC 2015

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 11, 2012 Jun 11, 2012

Copy link to clipboard

Copied

Go to Preferences (under the Photoshop menu on Mac, under the Edit menu on Windows) > Performance. Is "Use Graphics Processor" checked, or is it greyed out? If it is checked, click the Advanced Settings button and change Drawing Mode to Basic and retry.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 11, 2012 Jun 11, 2012

Copy link to clipboard

Copied

Lighting Effects in CS6 requires 3D functionality - so you will need a capable GPU, and an OS that can support OpenGL and 3D features (not XP).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

Ok the same thing is happening to me so I read this thread but the "Use Graphics Processor" is greyed out. I remember I was able to use the Lighting effects on past projects about a month ago but now I can't why is that?

I use Windows 7 64-bit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

Check Help -> System Info.

Your driver might not meet the requirements, or it might have crashed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2015 Oct 01, 2015

Copy link to clipboard

Copied

can you please help me confirm if my video card "Mobile Intel 4 Series Epress Chipset Family" would be compatible?

Support for the Mobile Intel® 4 Series Express Chipset Family

Graphics Drivers — Supported Graphics APIs and Features

Thanks in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 02, 2015 Oct 02, 2015

Copy link to clipboard

Copied

Chipsets are not really video cards. They are build directly into the motherboard (as opposed to video cards which plug-into a slot) and share resources with the rest of the board. For example, chipsets do not have any VRAM (memory set aside purely for video functions) but use the onboard RAM. This and other factors severely restrict the capabilities of these devices and do not meet to requirement of Photoshop for GPU functions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2014 Jun 07, 2014

Copy link to clipboard

Copied

I had exactly the same problem and here is the answer: update the driver for your video card. And when you update, go to the vendor website! (i.e. the vendor of the particular video card you have). If you don't know what kind of video card you have, use the commands: Control Panel/System/Device Manager, then double-click on "Display Adapter". It will display a tab called "Driver", which will give you the date of your current driver. If it is anything older than maybe a year, go to the vendor site and download the appropriate driver. My download was about 260MB in size. It also seemed to improve my screen resolution a little at the same time.

But there is more! Photoshop CC uses two things called OpenGl and OpenCL. I have no idea what they are, BUT, I think both of them must be selected in order for Lighting Effects to work on Photoshop CC. And where do you select these things? Edit/Preferences/Performance

video card settings.jpg

And finally, check the box "Use Graphics Processor", then click on "Advanced Settings". Under Advanced Settings you will see

Use OpenCL.jpg

And you guessed it! Click on the box "Use OpenCL". I have no idea if the 30 bit display box should be checked - I was trying everything at one point.

Anyway, it seems like Adobe has adopted new technology somewhere along the way, such technology not being included in video drivers just a few years old. Personally, I think Adobe should have made more of an effort to highlight this problem and provide an easier-to-figure-out solution.

Hope this helps!

Frank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2014 Dec 06, 2014

Copy link to clipboard

Copied

The answer is even simpler than you think... You need to work in 8 bits mode to use the lighting effect. To do this select:

Image/mode/8 bits/channel

and it should work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2015 Jun 25, 2015

Copy link to clipboard

Copied

Yup!! That worked instantly. all that other stuff did nothing. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

still not working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 06, 2017 Mar 06, 2017

Copy link to clipboard

Copied

still not working. my doc mode is 8 bit/channel RGB color

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

I am having the same problem.  I have tried the suggestions with no result...help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Ok so after trying everything else, I update the video card and it works.  Thanks for the suggestion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2017 Mar 23, 2017

Copy link to clipboard

Copied

SHOULD work,  and in a perfect world...but it didn't work for me.

Follow this path: Preferences, Performance, Advanced Settings, change Advanced to Basic, then click OK.

The last (critical) piece of the puzzle... I had to reboot. Works like a charm now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2018 Mar 29, 2018

Copy link to clipboard

Copied

It appeared for me but I can't move the position of the point lighting at all. Any suggestions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 14, 2019 Apr 14, 2019

Copy link to clipboard

Copied

This worked amazingly - though I was able to do it without a reboot, and just restarting the software

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

U saved me ❤️

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2017 Nov 27, 2017

Copy link to clipboard

Copied

I love you in a non creepy stalker sort of way - BLESS YOU!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2018 Mar 16, 2018

Copy link to clipboard

Copied

don't work even 8 bit color rgb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2015 Jul 28, 2015

Copy link to clipboard

Copied

Lighting effects and lens flare does not work in CMYK mode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2015 Aug 16, 2015

Copy link to clipboard

Copied

this really helped me with 8 bit.... thanx so much bro

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2015 Aug 23, 2015

Copy link to clipboard

Copied

ive tried all of that changing drawing mode selecting graphics processor and 8 bits mode but still not working. any other suggestions?

i keep swapping the file from one laptop to another using an older photoshop version just so i can add a lighting effect. Very annoying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines