Photoshop repeatedly freezing (Win 10)

Explorer ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Photoshop has been working flawlessly on this Windows 10 computer for a year now, but today suddenly the program started crashing repeatedly and often. It doesn't matter if I am actively trying to edit something, or just let the app sit idle, after a minute or two it will freeze completely and I have to manually stop it in Task Manager. Reboot didin't help, nor did instructions I found in posts here to disable native canvas, disable pan flicking, and I tried unchecking Use Graphics Processor" but it was already unchecked.

 

What else can I do to get Photoshop working again? I have the latest Photoshop version and there have been no hardware or software changes made to this computer in some time.

 

Thanks.

TOPICS
Windows

Views

85

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Aug 09, 2022 Aug 09, 2022

I reset the prefereces and restarted Illustrator and now I am gertting a big "Your graphics processor is incompatible" message which I do not recall seeing before. I skipped past it and was able to use it for a few minutes, but then it froze again. I unchecked Multithread Compositioning and that seemed to do the trick. Not sure why the sudden change, is my hardware nerhaps experiencingg a failure?

 

Either way it looks like I am back up and running, thanks a ton for the assistance, and I'll be bac

...

Likes

Translate

Translate
Explorer ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Try this solution, it might help:
Preferences > Plug-ins > uncheck everything.  
then restart PS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

There were only two things to uncheck, Allow Extensions to Connect to the Internet, and Load Extension Panels. I unchecked them both and Photoshop froze again within 90 seconds.

Thanks anyway.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

When Photoshop crashes, this is the first thing to do, try resetting your Photoshop preferences. Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) immediately after launching Photoshop. You will be prompted to delete the current settings. You can also reset preferences upon a quit if Photoshop is running by going into General Preferences>General>Reset on Quit.

Go to Preferences > Performance... and uncheck Multithreaded Compositing - and restart Photoshop.
Still crashing? 
Go to Preferences > Performance... click Advanced Settings... and uncheck "GPU Compositing" - then restart Photoshop. Still crashing? 

 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Hi California Gold!

 

Have you tried to install the preivous working version of photoshop? You can check out the process here: Install previous versions of your Creative Cloud apps (adobe.com)

 

In addition to what others have said, I also recomend posting your computer specs here and try installing the latest drivers for your hardware if we see something problematic with the list we can help provide suggestions as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

I just started having a similar issue.  I have a Dell XPS 15 9560 that has also worked great for over a year.  Recently, Photoshop started freezing regularly.  A message will pop up telling me my driver is not compatible.  I updated my drivers twice before realizing my NVIDIA GeoForce GTX 1050 GPU driver was being disabled.  I need to restart photoshop and check to make sure the driver is enabled.  It will work for awhile before disabling the driver, I hope this gets resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Hi Dean!

 

Could you post a new thread for your specific issue? We do want to help you and it will help allow us to focus better on you if user issues are isolated to their own threads. A quick thing to check in the meantime is to try to do a fresh reinstall of the latest drivers for your card. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

sure, thanks Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

LATEST

I reset the prefereces and restarted Illustrator and now I am gertting a big "Your graphics processor is incompatible" message which I do not recall seeing before. I skipped past it and was able to use it for a few minutes, but then it froze again. I unchecked Multithread Compositioning and that seemed to do the trick. Not sure why the sudden change, is my hardware nerhaps experiencingg a failure?

 

Either way it looks like I am back up and running, thanks a ton for the assistance, and I'll be back if it starts messing up on me again.

 

example 9 aug 2022.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines