• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

Picker always samples for background colour...?

Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Hi,

Probably a simple fix

but I'm on someone else's computer

so some of the PS settings are different

than mine.

I try to use the colour picker to get colour

in the foreground box, but it always automatically

goes to the background box.

Can someone tell me how to fix this please?
CS4

thanks

Views

67.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Deleted User
Jul 05, 2011 Jul 05, 2011

In the color panel make the foreground swatch the active one by clicking on it.

Untitled-2.png

MTSTUNER

Votes

Translate

Translate
Deleted User
Jul 05, 2011 Jul 05, 2011

Unless you have a stuck alt key or something, then the color choosen by

the eyedropper (foreground/background) is determined by which swatch is

active in the color panel. The active swatch should have a black square around it.

If all else fails, resetting the photshop preferences might set things straight.

Hold down the Shift+Alt+Ctrl keys while starting photoshop until you get a dialog

asking to delete the photoshop settings file and click Yes.

MTSTUNER

Votes

Translate

Translate
Participant ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Hm, pushing the <Alt> key puts the colour to the background.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Hello,

and in my case, holding ALT selects for the foreground colour!

It's backwards and it's irritating to work with...

Help?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Other comands work correctly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Now that you mention it, if I click my mouse button to zoom,

an Explorer page with PS Help pops up over and over.

Also really annoying!

Should I reset PS or the tools, you think?

If so, how?

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Reboot the computer! Either there is a Keyboard error (Keybord ALT is locked), or Photoshop thinks the ALT is locked. Clicking the swatches brings up the colour chooser!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Rebooted, but still same issue with colour picker!

Ugh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Are you using the eyedropper tool and it sets the background color or

it sets the background color when click on the foreground swatch at the

bottom of the toolbox to bring up the color picker?

MTSTUNER

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

When I use the eye dropper to sample a colour, that colour then

sets the background colour.

If I use ALT, with dropper, it sets foreground... which is opposite

of what should be happening.

Quite strange.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Unless you have a stuck alt key or something, then the color choosen by

the eyedropper (foreground/background) is determined by which swatch is

active in the color panel. The active swatch should have a black square around it.

If all else fails, resetting the photshop preferences might set things straight.

Hold down the Shift+Alt+Ctrl keys while starting photoshop until you get a dialog

asking to delete the photoshop settings file and click Yes.

MTSTUNER

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

Window->colour or F6: I can confirm this. Never used that feature to confuse me!   Pressing ALT inverses so selects the foreground.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2022 Sep 25, 2022

Copy link to clipboard

Copied

Usually it does, but if your settings have some how been switched in the color panel, it'll do the opposite. I have no idea how on earth I switched them up, but until I fixed it, I had to press alt everytime to get it to go into the foreground color box. When I figured it out, it was a told face slap, geez, why didn't i figure this out earlier moment ^_^

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

How'd u fix it?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 09, 2023 May 09, 2023

Copy link to clipboard

Copied

LATEST

True answer for OP's question

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

In the color panel make the foreground swatch the active one by clicking on it.

Untitled-2.png

MTSTUNER

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

It is the active one, but no matter what, when i use the picker, the background colour changes.

ALT click changes foreground... but should be reversed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

Thank you MTSTUNER was so frustrating before.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2019 Aug 16, 2019

Copy link to clipboard

Copied

OMG... thank you, this was KILLING ME

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

Thank you MTSTUNER! It saved my life!

 

____________________________________

my works

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

ty mtstuner, that was it. much appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

Bless your soul

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

AMAZING! 2021 here

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

A decade later, this comment is still saving lives. Thanks!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 05, 2011 Jul 05, 2011

Copy link to clipboard

Copied

MTSTUNER is right, though it may not be exactly clear what you have to do:

  • In Photoshop, choose Window - Color.
  • Note the two little squares to the upper-left.
  • Click on the foreground (upper-left) square, so that the outline is darkened.
  • From here on, unmodified color picking tools will update the foreground color.

ColorPanel.jpg

-Noel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2018 Sep 22, 2018

Copy link to clipboard

Copied

This solved my issue also (7 years later)!

Thx

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines