Polygon Lasso Tool Closes Selection at Random

Explorer ,
Nov 05, 2013 Nov 05, 2013

Copy link to clipboard

Copied

I am experiencing the same Polygon Lasso glitch that has been brought up by several others; however, I haven't seen a solution.  I'm posting again JUST IN CASE someone new sees this and can share how they may have overcome this frustrating issue.

Here’s the problem: Polygon Lasso decides to close the selection FOR NO REASON AT RANDOM.

Let me clarify that I am an advanced Photoshop user (certified expert by Adobe).  I know all Photoshop tools inside and out and this is DEFINITELY not user error. Photoshop CC is glitching and it needs to be fixed.  Thing is, this only started for me very recently; within the last few weeks.  (Kinda close to when I updated to Mavericks on my mac but I’m not sure that has anything to do with it)  

To re-iterate, this is NOT a double-clicking issue or anything done wrong by me. Making lots of small lassos joined by the shift key is also NOT a solution.  Switching to the pen tool is also NOT a solution because my workflow depends on the speed of the lasso tool.

The real reason why I’m bringing this up is mostly because, like I said, this is only a recent problem.  Was there just an update to Photoshop CC that would have caused this? It’s driving me crazy and putting a serious hiccup in my workday since the polygon lasso is such a key tool. 

Views

26.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Oct 26, 2014 Oct 26, 2014

Likes

Translate

Translate
New Here ,
Apr 19, 2015 Apr 19, 2015

Copy link to clipboard

Copied

i have ps7 and have had it for ever, and have had a pc of every os and no tablet/ i have had the same problem. no activity for 3 seconds and it auto completes. every other ps does it as well. i just signed up to hopefully resolve this .....thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 05, 2015 May 05, 2015

Copy link to clipboard

Copied

Same Problem on Mac, (MacbookPro 11,2 build 2014)Yosemite 10.10.3 on Wacome 21UX, I have had this problem since early Mavericks,

Polygonal Lasso tool works just fine with Magic Mouse and Logitech MX Master, its not functioning at all with wacom stylus, laggy, buggy, fills in and is random and useless.

any fixes yet.

I have the latest wacom drivers for Yosemite and latest OS software.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 02, 2015 Jul 02, 2015

Copy link to clipboard

Copied

I am writing in July 2015, and I am experiencing problems with the Polygonal Lasso Tool now.  I am using the recently installed CC2015. Frankly, I did not have this problem with previous version. My OS is Windows 7 Ultimate 64bit and I am using an hp wifi mouse as I did with the previous version. My productivity is now very low.

Paul

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2015 Aug 12, 2015

Copy link to clipboard

Copied

Amazing,  was having the same problem with all my tools, mainly Lasso and Brush - but this plugin from the below link solved my problem... Thanks a lot
Menus, shortcuts, Lasso tool, or Photoshop stop working when using a Wacom tablet | Mac OS

DONBARNUM thanks a lot
donbarrum

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2015 Nov 08, 2015

Copy link to clipboard

Copied

Hi Folks - Nov 9, 2015 now and still no solution.  For me the problem started with the upgrade to El Capitan and I suspect this may be the source of the problem. The lasso is (both forms) close randomly.  I have noticed delays int he clicking on my bluetooth mouse as well. The problem persists despite the Wacom plugin and the resetting of preferences fix that was suggested.  I have not gone so far as to resinstall CS6 as I am traveling.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2015 Nov 12, 2015

Copy link to clipboard

Copied

I have had the same issues, I reinstalled CS6 and no good, I thought it had fixed my problems at first but I was mistaken. This issue has to be fixed, why is adobe not doing anything?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Latest update fixes it!!!... it's about time

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2017 Jun 06, 2017

Copy link to clipboard

Copied

I correct my last comment.  Still doesn't work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2018 Feb 18, 2018

Copy link to clipboard

Copied

I had the same problem with my polygonal tool. I knew my new Logitech wireless mouse was super sensitive so I connect my old wired one. This has solved the problem for me.  I hope it helps. It's worth a try

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 06, 2019 Apr 06, 2019

Copy link to clipboard

Copied

I'm constantly on the search for solutions to this problem.  Every rabbit hole I find, I dive in.  Including this one.  Here is it, 2019, and I'm still having this problem.  The white workaround doesn't work around anything for me.  I'm on PC, Windows 10.  The polygonal lasso tool continually snaps closed before I've finished the selection, and I can only use it with the mouse.  Neither of my wacom tablets can use the tool at all because it sticks and becomes unresponsive.  It is the most frustrating issue I've encountered over the last several updates.  I used to have no issues with my pen tablet, but since several updates ago, my most important tool is no longer available.  No one, not Adobe or Wacom, can offer a solution that I haven't tried.  Updates to drivers, os, graphics card, new pen, new battery pack, command prompts, clean unstall/reinstall, ad nauseum.  This problem happens with my laptop and my desktop, two different tablets (one old, one new).  I despair of a solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 07, 2019 Apr 07, 2019

Copy link to clipboard

Copied

That's really strange, I haven't encountered this problem for years now.

What version of Photoshop are you using, the latest Photoshop CC?
Does it happen with the mouse AND the tablet or only the tablet? Or is the problem different between the two. Mouse closing the gap and the tablet sticking ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

LATEST

Please check my latest post in case you're still encountering this issue. It might just help you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

I know this is an old thread, but, for PC users this might help: I feel I've eventually managed to fix this glitch after many years by changing the compatibility mode for Photoshop CS3 (yes I'm still using CS3). I've run numerous tests trying to break the fix, and so far it's stood up to it. I'm running Windows 10, 64-bit on PC. Opening the program properties (right clicking on the shortcut, then go to Compatibilty tab) then tick "Run this program in compatibility mode for:" and choose Windows 7 from the dropdown box. I can't guarantee this is the issue, or that it will definitely help others, but it just might, so posting now just in case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines