Prevent crop making me use flatten image in P'shop2020

New Here ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

When I crop an image in Photoshop 2020, it makes a new layer.

How do I disable that so that I don't have to flatten the image?

Views

954

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 23, 2020 Mar 23, 2020

In the Crop Tool options check Delete Cropped Pixels

 

dcp.jpg

Likes

Translate

Translate
LEGEND ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

If the crop tool or on menu Image>Crop is adding a layer or flatting your document something is messed up on your machine. Try resetting your Photoshop preferences see if the fixes your problems.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

How do reset the preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

image.png

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2020 Mar 23, 2020

Copy link to clipboard

Copied

Oh, you meant a complete reset. Hmm!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

That is a preview layer for cropping only, once the crop is okayed, your layers return to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

If its the crazy crop preview in  the layers palette you are referring to that Chuck wrote about. You can use the crop tool settings in to tool options bar to switch classic Crop tool.  That does not show that preview where the document looks lake a flattened layer over a solid fill background.  I never look at it anyway.  

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2020 Mar 23, 2020

Copy link to clipboard

Copied

Mine doesn't return to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2020 Mar 23, 2020

Copy link to clipboard

Copied

When you commit the Crop the Layers palette should return to normals for the cropped  document. All your layers should be intact and cropped. There should be no extra layer added and the document should not be flattened. Here are screen captures that show what I see happen on my Windows 10, Photoshop 2020 version 21.1.1 workstation. Can you poste screen capture of how your machine works?

Capture.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2020 Mar 23, 2020

Copy link to clipboard

Copied

Could you please post a screenshot taken at View > 100% with the pertinent Panels (Layers, Channels, Options Bar, …) visible? 

Is »Content-Aware« checked for example? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2020 Mar 23, 2020

Copy link to clipboard

Copied

In the Crop Tool options check Delete Cropped Pixels

 

dcp.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

Bingo! Simplicity takes the gold star. Thank you so much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

I see you did not see I had that checked in the three screen captures I posted.  So a picture is not always better than words.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

I'm a writer first, photog second. So that should explain it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

I can not type or read so I use pictures its  my problem

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

LATEST

Thank you, Jeff Arola.  Your solution is elegantly simple, and IT WORKS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines