psd & psb files turn black

Community Beginner ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

After I've upgraded to Monterey and Photoshop 23.5 I'm having issues with mainly large (2 GB) psd and psb containing smart objects. As long as I'm working on the fil, no problem. As soon as I quit the file and reopen it, the file is black - or, on a good day, cut out in black and colored squares.

There's nothing to see when I preview the file and if its placed in Indesign, there's nothing wrong either. If I open the smart object everything is fine. Until now - and before I upgraded to Monterey + had an older version of photoshop, I got around the problem by placing the smart object in a new photoshop file so I could work in the file. Not a solution that lasts, plus now it happens to ALL my psd/pbs containing smart objects regardless the size…

Anyone have any suggestions on how to solve this issue?

TOPICS
macOS

Views

91

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

I seem to recall video drivers going kablooey for Mac users that Photoshop seemed to exploit. That was some time ago (and it was on Apple, who eventually fixed it). Did you contact them to see what they say?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

no, not yet…

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

I don't know what your settings are, but look under Preferences > File Handling and set Maximize to "Always" and restart Photoshop.

Screen Shot 2022-09-05 at 3.17.54 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

You may have to resave your files to get the composite image maximize compatibility provides.

Just do a "non-destructive save" by turning layer visibility (layer eyeball) off then on for a layer, then close the file. Then you should have a good thumbnail.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

LATEST

First, try disabling GPU in the Preferences (Performance tab). Any better?
You can try this too: in Preferences>Technology Previews, check the box 'Deactivate Native Canvas' and uncheck 'Enable Native Canvas Rulers' options, then restart Photoshop. Does this work?
If not, recalibrate and build a new ICC display profile, the old one might be corrupted.
If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile.

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if this is the latest OS version, you may need to roll back a release.
Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html
https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Save time with Adobe Express quick actions